Reply to post: Same with Ubuntu but different solution

Dealing with legacy issues around Red Hat crypto versions? Here's a fix

Henry Wertz 1 Gold badge

Same with Ubuntu but different solution

I had the same problem trying to connect to voltron, my one system running Ubuntu 11.04 (but a much newer kernel, 5.4.0-109-generic currently) had this issue. They do not supply a update-crypto-polcies command, so I had to put the following into /etc/ssh/ssh_config (and sshd_config so if you want it to be able to connect to a Ubuntu 22.04-running system.)

HostKeyAlgorithms +ssh-rsa

PubkeyAcceptedKeyTypes +ssh-rsa

First line to connect at all, and without the second line I had to supply the password every time, even though my keys were copied over already (ssh-copy-id).

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon