Reply to post: Can't update (some) Dell BIOS FW if virtualization is turned on

Dell SupportAssist contained RCE flaw allowing miscreants to remotely reflash your BIOS with code of their creation

fidodogbreath Silver badge

Can't update (some) Dell BIOS FW if virtualization is turned on

I have two Dell laptops. On both of them, Dell's Windows-based firmware updater ran and said it was successful (pending restart); but on restart the firmware did not actually update. I should note that these are very different machines: a 6th-gen i7 ultrabook and a 10th-gen i7 workstation, both running Windows 10 20H1.

I tried Command Update and stand-alone firmware installers, all run as admin. Same result.

After many Google dead ends, the solution was to turn off Intel Virtualization Technology in the BIOS settings, then boot into Windows and run the updater. On restart, both machines then actually performed the BIOS update.

After confirming that everything was working and the correct BIOS was installed, I went back into the BIOS settings and turned Intel virtualization technology back on.

This updater bug is especially dangerous because it looks like the BIOS update worked. After the mandatory restart, there is no indication that the firmware was not in fact updated. You wouldn't know that it wasn't unless you watched the screen during restart and/or ran another update scan.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2021