Reply to post: I was with them from the start, and it was amazing except for the catastrophes

Revolut-won: British banking app gets half a billion bucks in backing, seeks to subvert today's market incumbents


I was with them from the start, and it was amazing except for the catastrophes

I joined Revolut very early on - for me, where I move around a lot, it was a gift from the Gods; multiple currencies, one card, no fees, market rate. I was one of the 5000 people who had the chance to buy stock, early on.

It was all okay until the catastrophe - the app, without warning, required Android 5, and I had Android 4.4. Out of the blue, my account stopped working. This was about two years ago.

I still have about 1000 GBP in the account. Revolut say the only thing they will do is return the payments to the people who made them. They will not transfer it to another account.

Before this happened, though, I started work as a contractor and took out a business account. I used this very very happily - it's all web-based, so no problems with apps - and covered myself completely against Brexist by moving everything into CHF.

Everything was great until the catastrophe.

Out of the blue, without warning, Revolut introduced an app, and the app is required to make card payments on-line. So I was no longer able to use the account on-line.

Fortunately, I could still make transfers via the web-site. I've emptied the account (actually also terminated the company) and I'm about to close it.

Revolut IME are fantastic, except that they have no culture of ensuring all accounts work at all time.

That approach might be okay for, say, a food ordering app, but when it's your *banking* app, and your *money is in there*, and your business might depend on it, well, it means you can't rely on Revolut. By all means use it, but for the love of God, make sure you can function completely without it, and with it disappearing instantly, without warning.

(I tried to get the apps running on an Android VM on my laptop. I think Revolut do not publish for x86/x64, only for ARM - they used to do x86/x64, but stopped a long time ago. However, I'm not quite sure about this - it might be I cannot see the apps because they are restricted to the EU. My virtual machine has no location set. To set a location, you have to provide a bank account - yes, really. I'm not going to give my bank account info to Google, so I can't set location, so if the problem is that the app is restricted to the EU, I can't fix it. N26 and Transferwise do not have this problem; they won't run on my phone either, but it's no problem, I run in them in the VM. I think though in fact they just don't publish for x86/x64. You can download the APK on the net, directly, but you can only find ARM except for very very old releases.)

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon


Biting the hand that feeds IT © 1998–2021