back to article VMware giving away Workstation Pro, Fusion Pro free for personal use

VMware has made another small but notable post-merger concession to users: the Workstation Pro and Fusion Pro desktop hypervisor products will now be free for personal use. The cloud and virtualization biz, now a Broadcom subsidiary, has announced that its Pro apps will be available under two license models: a "Free Personal …

  1. Anonymous Coward
    Anonymous Coward

    Great chance to get some free experience

    Or am I being a bit slow ?

    1. Wzrd1 Silver badge

      Re: Great chance to get some free experience

      I trust them as much as I already did, back when they promised be free.

      aka, fuck them as they did us.

      1. matjaggard

        Re: Great chance to get some free experience

        I'm not sure it's very valuable. Anything you do with these can never be used for making money. I'm not sure about other people but even on personal projects I'm always aware that my work could be valuable but if I started on one of these products I never can. Even a document I create inside a VM could never be used for business purposes presumably.

        1. Happy Lemming

          Re: Great chance to get some free experience

          If you develop your Killer App in a personal-use environment, and foresee a pile of coin, simply buy a commercial license.

  2. may_i

    They have hidden it well

    Just created an account at support.broadcom.com

    I can't find anywhere to download VMWare Workstation.

    Well played Broadcom! Make the product free for personal use but make it impossible to find and download.

    1. zimzam

      Re: They have hidden it well

      The store is still down for an update. It was supposed to be back up yesterday.

      1. J. Cook Silver badge

        Re: They have hidden it well

        Yup; I went to a meeting with our VAR and our new broadcom reps, and the reps told us that they can't do quoting until the end of the month at the earliest.

        :: shakes head sadly ::

      2. UnknownUnknown

        Re: They have hidden it well

        Broadcom’s website is an incoherent pile of bollocks. Hard to find anything.

        1. Anonymous Coward
          Anonymous Coward

          Re: They have hidden it well

          "Broadcom’s website is an incoherent pile of bollocks. Hard to find anything."

          That sounds pretty much the same as VMware's assortment of webshites ever were. Every time I needed to download a new version of VMRC, it was always a real pain to try to find it…

      3. Stuart Castle Silver badge

        Re: They have hidden it well

        When I checked, it was, rather confusingly, listed under the "VMWare Cloud" group of products.

        1. jack d
          Headmaster

          Re: They have hidden it well

          Yeah, I spent over 40 irritating minutes searching, finally found it, downloaded and installed the Workstation Pro 17.5.2 but... I use Virtualbox every day for over 15 years now, but since I already lost my enthusiasm for VMWare due to their site being so easy to navigate, I became too lazy to install windows from scratch in a new machine, so decided instead to import an .ova device made from the working windows VBox machine. Unfortuantely, VMWare found that .ova's device line 16 and 19 were not compatible and so, that was it for me. Maybe next time.

          But anyway, good luck for other enthusiasts and thank you VMWare/Broadcom for a nice gesture.

    2. Dave@Home

      Re: They have hidden it well

      VMware Store

      Down for Maintenance

      As part of the transition to Broadcom systems, the store will be moving to a new domain. As a result, store will be shutdown between 30 Apr to 13 May.

      For more information, see KB article 319284.

      1. czuk

        Re: They have hidden it well

        And of course the linked KB article returns 404

        1. Fruit and Nutcase Silver badge
          Linux

          Re: They have hidden it well

          Bet that VMware site 404 page is not as neat as this...

          https://www.theregister.com/Design/graphics/icons/404_img.jpg

      2. Howard Sway Silver badge

        Re: They have hidden it well

        If they have to shut down their store for 14 days just to move it over to a new domain, it doesn't inspire much confidence in their product. I've done similar domain transfers and they took a few seconds to occur from the point of view of external users. From a company that thinks of themselves as the kings of virtualization, and could therefore have had both old and new running simultaneously using their own actual product, this should have been even easier.

    3. Timbo

      Re: They have hidden it well

      I found it here:

      https://www.vmware.com/content/vmware/vmware-published-sites/us/products/desktop-hypervisor.html.html

      1. Timbo

        Re: They have hidden it well

        and clicking that link leads to here:

        https://store-us.vmware.com/workstation_buy_dual

        which currently says:

        [quote]

        VMware Store

        Down for Maintenance

        As part of the transition to Broadcom systems, the store will be moving to a new domain. As a result, store will be shutdown starting 30 Apr 2024.

        To be notified when store is back and operational, enter email here. (link to: https://www.digitalriver.com/cloudvista.)

        For more information, see KB article 319284. (link to: https://knowledge.broadcom.com/external/article?articleId=319284 )

        Thank you for your patience.

        We apologize for any inconvenience.

        [/end]

        So, just bookmark it and come back some other time?

        But BAD PR from Broadcom to announce this and make it unavailable.... :-(

        1. katrinab Silver badge
          Windows

          Re: They have hidden it well

          It is up now.

      2. Local Laddie

        Re: They have hidden it well

        Nope, you didnt! But good try!

        the url reports

        "VMware Store

        - Down for Maintenance-"

    4. EricB123 Silver badge

      Re: They have hidden it well

      "Make the product free for personal use but make it impossible to find and download."

      Are you going to complain about EVERYTHING?

      /s

  3. Anonymous Coward
    Anonymous Coward

    So long and thanks for all the fish

    No thank you I moved away from that environment years ago and have no interest in moving back into it

    1. captain veg Silver badge

      Re: So long and thanks for all the fish

      Same here. It was the constant changing of what constituted the free version that did it for me. This seems like more of the same.

      I've been happily using VirtualBox since it was open-sourced.

      -A.

      1. Jou (Mxyzptlk) Silver badge

        Re: So long and thanks for all the fish

        I stick to Hyper-V. Included, works.

        1. captain veg Silver badge

          Re: So long and thanks for all the fish

          > Hyper-V. Included, works.

          Not here. I run Windows inside virtual machines, not on the metal.

          -A.

      2. Michael Wojcik Silver badge

        Re: So long and thanks for all the fish

        I've been surprised at how well VirtualBox works. There's the trap of the Oracle extension pack, or whatever it's called, which is another of Oracle's licensing Trojan horses; but if you avoid that, VirtualBox seems like a good choice for casual desktop-VM purposes.

    2. Grogan Silver badge

      Re: So long and thanks for all the fish

      I used to pay for VMWare Workstation. I didn't mind, because there was an employee (Petr his name was) that was very good at porting the module glue to new kernel releases. As soon as I hit a snag and couldn't compile the module I'd go look and he'd have snippets in the forum. So I got along with that.

      One day that stopped (I guess he was assigned to other things?), and while I still got along, they suddenly switched to a GUI installer that didn't work. I paid for an upgrade and couldn't even get it off the ground. They refer you to their "system requirements" reinforced by their forum nannies. That in itself felt highly insulting, because I had spent a lot of time helping users with their guest OSes and stuff in those forums.

      I solved my problem by switching to VirtualBox. At that time it wasn't as good (started getting better, fast), but I got along with it well and you didn't hear them whinging about supported kernel versions, though in the end it did prove to be a lesser, but similar nuisance that way. I got tired of getting over my head with kernel code and having to wait.

      I eventually just switched to Qemu and used that with no front end (entire VM in the command line) and because Qemu itself is just a front end to KVM in kernel, I used that same Qemu binary I built for like 4 years and the kernel interfaces never (and still haven't, to my knowledge) broke it, though I'm using newer stuff now with a virt-manager front end on a different system.

      People don't have to pay to run virtual machines anymore.

      So yeah, so long and thanks for the fish. That ship has sailed etc. etc. :-)

      1. Morten Bjoernsvik

        Re: So long and thanks for all the fish

        >I solved my problem by switching to VirtualBox.

        We had a Oracle audit and they found a single virtual box running in our environment. I managed to shut it down before the final audit.

  4. Contrex

    The update server is still up, and you can download a tar archive of the Windows installer for 17.5.1

    https://softwareupdate.vmware.com/cds/vmw-desktop/ws/17.5.1/23298084/windows/core/VMware-workstation-17.5.1-23298084.exe.tar

    I just did it, and in the newly installed Workstation, clicked 'Help' in the menu bar, then 'Software Update' and was offered 17.5.2 build-23775571 which downloaded and worked fine, along with drivers, etc.

    By the way, I suppose we won't now be needing the free licence serials that bloke on Github has been allowed to give away for a while now?

    1. Jou (Mxyzptlk) Silver badge

      Surprise...

      wget https://softwareupdate.vmware.com/cds/vmw-desktop/ws/17.5.2/23775571/windows/core/VMware-workstation-17.5.2-23775571.exe.tar

      worked! Thanks for giving the exact version information!

      1. This post has been deleted by its author

        1. Jou (Mxyzptlk) Silver badge

          .exe file size means nothing. Checksum + size identical does.

          17.5.2 is supposed to fix the new CVE-2024-22267

          1. Mike McC

            Thanks. I found the release notes for VMware Workstation 17.5.2 Pro Release Notes on https://docs.vmware.com/en/VMware-Workstation-Pro/17.5.2/rn/vmware-workstation-1752-pro-release-notes/index.html which confirm what you wrote: (This release resolves CVE-2024-22267, CVE-2024-22268, CVE-2024-22269, and CVE-2024-22270.)

      2. LemonTree3

        Ok for Download, but it still puts you on a 30 day trial without a license

        The download and the update to 17.5.2 worked great! Thanks for that info. However without a license key the new install just puts us into a a 30 day trial. Any Insights on that?

  5. Anonymous Coward
    Anonymous Coward

    try this to get access of binary after loggin in support portal : https://support.broadcom.com/group/ecx/productdownloads?subfamily=VMware%20Workstation%20Pro

  6. This post has been deleted by its author

    1. RedGreen925 Bronze badge

      "Virtualbox locally"

      That is nothing to brag about supporting those scumbags at Oracle is just as bad. The day it was announced was the day I uninstalled it. And I was none too happy with Sun either but at least they did the odd good thing...

    2. Dan 55 Silver badge

      Don't download the VirtualBox Extension Pack or you'll have a Oracle hit squad waiting in reception for you.

      1. Tom Chiverton 1

        Extension pack has me been a requirement for years

      2. Telman
        Joke

        Where I live, that is just a "Target Rich Environment" :)

      3. werdsmith Silver badge

        No Oracle means no VirtualBox, no MySQL, no Java, no exception.

        1. Gaius

          But what are the downsides?

  7. Unexploded

    It's free, if you can find it. Forgot just how how much I hated Broadcom's site.

  8. Groo The Wanderer Silver badge

    I'll stick with the copy that's already paid for that has a PERPETUAL license instead of a subscription, thanks.

  9. Plest Silver badge
    Mushroom

    Broadcom...stuff your charity up your wotnot!

    You wait until they change the license terms again and then screw all those suckers who downloaded it for free, they got your details and they'll be after you for a £25 license this time next year when takings are down. I draw your attention to how Oracle did that exact same thing with the Java runtime.

    Broadcom can f**k off, wouldn't touch your shite with another person's 10ft barge pole!

  10. karlkarl Silver badge

    Its always been free.

    You download the binaries for Win/Lin/Mac from VMware's website.

    And then you google for the version + keys + github and usually can find a repo with a listing of serial keys.

    What is surprising is that VMware has never had any DRM in it.

    What you have now is less free:

    https://www.vmware.com/content/vmware/vmware-published-sites/us/products/desktop-hypervisor.html.html

    No longer do they allow you to simply download the installer.

  11. chivo243 Silver badge

    Kind of pointless on the Mac

    when this is out there... https://mac.getutm.app/

    But ya gotta have Apple Sillycon...

    1. Anonymous Coward
      Anonymous Coward

      Re: Kind of pointless on the Mac

      It does also run on Intel-based Macs, not just Apple Silicon

      1. chivo243 Silver badge

        Re: Kind of pointless on the Mac

        I tried on my Intel based fruit, and the installer balked... I glanced at the site once more before posting and missed that part. It's hell getting old!

    2. John Robson Silver badge

      Re: Kind of pointless on the Mac

      Given how crap vBox has been recently... thanks

      It does support intel macs as well, and supports emulation for cross architecture work.

      The thing that's limited to apple silicon is macos guests in macos (I think)

    3. Bebu Silver badge
      Windows

      Re: Kind of pointless on the Mac

      UTM works surprisingly well.

      The x86 emulation on apple(arm) silicon is usable.

      I had reason (need) to run both FreeBSD (amd64) and CentOS7 this way. Yes the world is that perverted.

  12. Michael Hoffmann Silver badge

    Timeo danaos et donas ferentes

    Always wanted to have a good occasion to use that one: I fear the Greek, even when they bear gifts.

    So, what's the catch?

    1. Bebu Silver badge
      Windows

      Re: Timeo danaos et donas ferentes

      《even when they bear gifts.》

      Especially when they bear gifts.

      As a teen age reader I was puzzled why the Trojans didn't drag the horse onto the plain and stick a match to it - I am sure Kassandra would have done the honours.

      Now I guess the horse had some religious or symbolic significance for the Trojans and would have been seen as an offering to their gods by the departing Achaeans and destroying it sacrilege.

      Odysseus had a lot in common with contemporary corporate (lack of) values - certainly count your fingers after a handshake with either.

      1. Michael Hoffmann Silver badge

        Re: Timeo danaos et donas ferentes

        Wasn't that because of divine intervention? The Greek supporting gods got up earlier than the Trojan helping ones, so any naysayers (Laokoon and his sons, for example) were silenced.

        1. Bebu Silver badge
          Windows

          Re: Timeo danaos et donas ferentes

          Wasn't that because of divine intervention? The Greek supporting gods got up earlier than the Trojan helping ones, so any naysayers (Laokoon and his sons, for example) were silenced.

          Sounds right. The Trojan faction on Olympus were more the party girl types if I recall correctly while the Achaean faction more the bluestocking and more likely early risers. :)

  13. streaky

    Virtualbox?

    I thought everybody had figured out that you can just use kvm/qemu at this point, with a side bonus of it even runs under WSL2 if you're a Windows user..

    As for topic, isn't the entire business world running away screaming?

    Basically there's no reason for vmware to exist at this point, last one out please turn off the lights.

  14. Tom Parkinson

    broadcom downloads ... KLAXON tangodown

    oh dear ... tried and tried to download free mac os one - getting <OID API call failed> - ferrgeddaboutit.... yep folks its free but also impossible to get hold of an installer... ffs move along nothing to see

    1. chivo243 Silver badge
      Facepalm

      Re: broadcom downloads ... KLAXON tangodown

      Arrr, you're not trying hard enough ya scurvy dog... I'm sure someone has accidentally shared this file somewhere. Now wAAAR ya gonna look?

      1. WolfFan

        Re: broadcom downloads ... KLAXON tangodown

        Some of us don't care enough to bother hunting it down. If it's not available from the vendor after they promised free installers, I take that as a hint and stay far away.

        1. Judge Jury Executioner

          Re: broadcom downloads ... KLAXON tangodown

          https://support.broadcom.com/group/ecx/productdownloads?subfamily=VMware%20Fusion

          https://support.broadcom.com/group/ecx/productdownloads?subfamily=VMware%20Workstation%20Pro

  15. Mike McC

    Locked out of VMware and Broadcom support

    Broadcom could certainly be doing a better job in looking after its acquired VMware customers! The old VMware site has shut down and I can't log on to the new Broadcom support site https://support.broadcom.com/! Password reset appears to be broken at the moment.

    At least The Register remains a great source of reliable information, even if Broadcom is struggling!

  16. JonL82

    It doesn't really get you much...

    Looking at the comparison table:

    https://web.archive.org/web/20240211232610/https://store-us.vmware.com/compare_workstation

    (As their site is down.)

    Really the only thing you'd really want over Workstation Player is Secure Boot. You can run multiple VMs at once with the free Player, and other Pro things are of very limited use (Snapshots maybe to some).

    I'll update to it of course... and I find it better than the alternatives for me, maybe I'm out of date on how they are with 3D graphics, etc.

    1. Fruit and Nutcase Silver badge

      Re: It doesn't really get you much...

      A long time ago, I used VMware Workstation to create a VM image of my laptop which was running XP at the time, prior to installing Linux and then running the prior OS as a guest whilst transitioning to Linux. That imaging process was painless and "just worked"

  17. GraXXoR

    Workstation Pro and Fusion Pro: free for personal use....

    ... until they aren't.

    fool me once, shame on you. fool me twice...

  18. talk_is_cheap

    So the gateway product is now free for learning!

    After which you can try ESXi and perform your first business deployment using the entry-level cost vSphere essentials kit................

    Oh, so much for that progression.

    I think most people are rather busy dealing the major budget issues they have due to all the product and price changes to vSphere.

  19. samzebra

    Vaporware

    FREE, but "down for maintenance" when you try to download...

  20. Reiki Shangle
    Pint

    Free as in, of no value…

    At least Broadcom are making their intentions and actions clear. In a crowded virtual and container market, I doubt I’ll use Fusion again. They’re clear about the value of the product to them; zero. The VMware business strategy was never clear, never ambitious nor extensive, sometimes weird (I’m talking about the RabbitMQ acquisition, which is a great product, but surely a sore thumb), and so much potential was squandered.

    At least they’re not Google.

    1. Blue Pumpkin

      Re: Free as in, of no value…

      No they're CA - where software goes to die ... sums it up really

  21. mili

    the first trip is always free

    isn't it?

  22. JulieM Silver badge

    Bait

    Making proprietary software available to use gratis is never a nice gesture. A nice gesture would be releasing the Source Code. What Broadcom are doing is a transparent attempt to tempt you and lock you into their proprietary system.

    In the worst case, they could even start charging you for it once you are well and truly dependent.

    They are obviously worried that Open Source competitors are, or will soon be, gaining ground on them. Don't fall for it, kids!

  23. Stuart Castle Silver badge

    I use VMWare a lot. I have a licence that covers me for the Pro versions of both Fusion and Workstation. Obviously I can get both for free now, but I needed the license years ago..

    I'm aware there are perfectly capable free solutions. For instance VirtualBox or Proxmox. In fact, in my attempts to update my knowledge on Windows System admin, I installed Proxmox on an old PC, giving it a couple of SSDs, then set up a complete domain in VMS on that machine.. It won't wine any awards for performance, but it isn't a production setup. Speed doesn't matter much.

    But, part of my job is packaging software for deployment. Some of which is quite hardware intensive, and really doesn't run well on Virtualbox. So, I needed VMware for that..

  24. CPU

    I just tried to D/L Workstation... good luck with that!

    Off to download the "free" VMware Workstation...

    The Broadcom site makes you register, so forget the old VM account login, no use here. NB You can't D/L from the VMware website any more.

    The new site insists I "build a profile"... OK done.

    I search around for downloads, find the new 17... but it won't let me D/L it, seems I'm not allowed access to software as it's not "part of my Profile"- back to Profile Builder!

    OK, cool I find the option to access VMware software within Profile Builder, but now it wants account details as though I'm a paying customer, and that is a VMware SiteID.

    Has it not crossed Broadcom's mind that if someone is downloading Workstation for "Personal Use Only" they might not be a paying customer?

    They should put Workstation in the default Profile Setup as a given.

    1. Judge Jury Executioner

      Re: I just tried to D/L Workstation... good luck with that!

      Here are the download links for both products (you need to have signed up for a support account first) - make sure you tick the box to agree download terms and the download button will then be enabled.

      https://support.broadcom.com/group/ecx/productdownloads?subfamily=VMware%20Fusion

      https://support.broadcom.com/group/ecx/productdownloads?subfamily=VMware%20Workstation%20Pro

  25. Quentin Finknottle Again

    I had most of the problems described above but eventually, somehow, I got to here:

    https://support.broadcom.com/group/ecx/productdownloads?subfamily=VMware%20Workstation%20Pro

    If you are logged in, it should offer Workstation Pro 15 - 17 plus workstation 17 personal.

  26. Judge Jury Executioner

    Website download URLs

    For ease of reference, pls find them listed below - you will need to have signed up for a Broadcom support account before hand, and in order to download the products (only the latest version can be downloaded), accepting the t&cs will enable the download link.

    https://support.broadcom.com/group/ecx/productdownloads?subfamily=VMware%20Fusion

    https://support.broadcom.com/group/ecx/productdownloads?subfamily=VMware%20Workstation%20Pro

  27. senpai

    PR stunt ?

    Judging by the pile of hot *** thats broadcoms website and the need to be entitled by a customer support site ID .. for paying customers to download whats said to be a free player seems more like a PR stunt to me.. #ImNotEntitled

  28. Mickey Porkpies

    run for the hills

    migrate now before you get even further hooked

  29. Donn Bly

    Not sure what making it free does for us. I have already paid for it, but cannot download it to put it on my new laptop. In fact, I can't get to ANY of my entitlements. Even created a support case the first of the week and provided them with copies of the contract numbers and everything, but now when I try to log in to see the status of the case I just get an "error, please try again later".

  30. b1k3rdude

    Im waiting for the other show to drop.....

  31. Bartholomew
    Happy

    What worked for me

    On my second attempt I was able to download the Windows version with these instructions:

    1. Open your web browser and go to broadcom.com, then login or create an account

    (maybe have a coffee between these two steps, I was rushing)

    2. Goto: https://support.broadcom.com/group/ecx/productdownloads?subfamily=VMware Workstation Pro

    3. On the page, locate the “VMware Workstation Pro for personal use". You will see various installer versions for different operating systems (e.g., Windows, Linux).

    On my 5th attempt the link "VMware Workstation Pro for personal use (Linux)" worked!

    1. senpai

      Re: What worked for me

      Did have that coffe and worked for me also after giving away personal information and promising i wouldnt use it for anything the US goverment wouldnt approve of yay!

      :)

  32. simmonsm

    Here is a good assessment of what Broadcom have screwed up in how not to create a website!

    https://matduggan.com/the-worst-website-in-the-entire-world/

    Enjoy...

    1. David 132 Silver badge
      Thumb Up

      >https://matduggan.com/the-worst-website-in-the-entire-world/

      Bravo!

      > Enjoy...

      Oh, I did. What a great takedown of an absolute train-wreck of a website. Thanks for sharing!

      1. simmonsm

        I'm glad you found it enjoyable. believe we should not mistake total incompetence for malice (making it hard to find 'free' vmware products like this deliberately), though. I mean, the website behaves like a bad AI-generated rats nest.

  33. tip pc Silver badge

    Broadcom don't do free

    Broadcom don't do free

    They are getting paid, I’d suggest taking an interest in the telemetry

  34. Mishak Silver badge

    Terms and Conditions

    I'm currently on Fusion 12 and was probably going to upgrade later this year, so I'm happy to take "free".

    However, I'm not sure I can be bothered to read 29 pages of T&Cs! Anyone got a summary?

  35. Mishak Silver badge

    So, how do I register an account for personal use and then use it to download?

    I can register, but I then have to "complete my profile" before I can download anything. Ok, I can live with that.

    However. the "software" section of the profile (which seems the right bit to complete) requires a phone number (easy enough) and a site ID - which I don't have as this is for personal use!

  36. guyr

    Other free options have existed for over a decade

    Like others, I use VirtualBox for my personal VM needs, have been doing so for over a decade. So, I don't really understand why free VMWare is such a big deal. I guess if you use the paid version in a work environment, having the same available as a free option for non-work environments makes sense. Would have made more sense 10 years ago before people were forced to find other options.

    1. werdsmith Silver badge

      Re: Other free options have existed for over a decade

      You don’t really understand why people would want to avoid Oracle?

  37. James O'Shea

    still no access

    The download link still doesn't work.

    It's got to be deliberate.

    1. WolfFan

      Re: still no access

      It's up now. But you have to register.

      I don't care that much.

  38. Anonymous Coward
    Anonymous Coward

    One of Broadcom's IT rules distributed to vmware minions shortly after the acquisition was that installation of virtualisation environments on corporate laptops was forbidden. This definitely caused some head scratching.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Other stories you might like