back to article Ubuntu 22.04.1: Slightly late, but worth the upgrade

The first point-release of the newest Ubuntu is here, which marks the stage it formally becomes the new long-term-support release. As we mentioned last week, there were some last-minute delays in the 22.04.1 release process. The release was delayed until August 11. But now it's here, as Canonical announced on its official blog …

  1. EvaQ

    I checked, and it seems my laptop is already on it:

    $ lsb_release -d

    Description: Ubuntu 22.04.1 LTS

  2. MrReynolds2U

    No problems here

    Coincidentally I've just done a bare metal installation of Ubuntu Server 22.04.1 this afternoon and that went really smoothly too on a rather decrepit DL-380 G6? (IIRC)

  3. Avid

    Upgrade didn't work for me

    I was using the prior xubuntu LTS and waiting for the notification of this .1 LTS, figuring it'd be stable. Which I received last night and did the one click. Instead the upgrader gave an error on glibc which (thankfully only) temporarily bricked the laptop. (Didn't realize hitting F1 incessantly on a Lenovo would enter bios otherwise it would stay a brick.) So I had to copy my data off to an external and then just do a fresh install of the latest Xubuntu. At least the latter works! So just thought I would post as a note of caution that unfortunately my experience was not foolproof, but at least I learned something

  4. Paratrooping Parrot

    Update from Fossa went bad

    I had a difficult time updating from Fossa, it eventually managed most of it after deleting some packages. It eventually gave up on installing gdm3 because of issues with cpp, x11-xserver-utils. I had to download the iso file and install it over my Ubuntu setup. Eventually got my Firefox back up and running as before.

    So, do make a backup of your system beforehand. I had no problems with upgrading from 16.04 to 18.04 to 20.04. It just died at 22.04. Oh well...

  5. 4d3fect

    Just got the notification to upgrade from 20.04.4. Guess I should look over the release notes.

  6. botfap

    The new standard in bloatware sadly

    Ubuntu 22.04(.1) Desktop is a mess sadly, its an under performing mass of bloatware that uses 2-3 times the RAM it should do and a similar amount in wasted disk space

    Ive been a long term Ubuntu desktop user for a decade (since 12.10) and a dabbler with Ubuntu since 5.04. Prior to that I was a SuSe Desktop user and before that I ran Slackware. The reason I switched my primary systems to Ubuntu in the first place was performance. SuSe had far better management tools with YAST (and still does) but Ubuntu offered a slimmed down, better performing, more constant desktop experience than any of the other distros. Its underlying core was well thought out and laid out (and still is mostly) and its default desktop and GUI app choices were well optimised, best of breed, well integrated app selections. With the release of 16.04 (actually in 2015 but I only use LTS releases on our workstations), Canonical changed its internal development direction. It wanted to reduce the cost of development internally so it started to rely more what was being developed by others and spend less developing and optimising internally

    The first major external sign of this was the replacement of upstart with systemd, a backwards step that made system configuration and troubleshooting more complicated than the traditional methods with no appreciable increase in functionality. SystemD also doubled the RAM use for a barebones, stripped down install used as app hosts in VMs. Suddenly our minimal VMs would no longer run with 16-32MB of allocated RAM. You needed 64MB ram just to run an SSH server. Bah humbug but not enough of an issue to change my entire toolstack for 80-90 employees

    Then we had Gnome 3. Another big increase in RAM and storage requirements came with it and a corresponding performance decrease caused frustration. For the first time we had to add 3D accelerated gaming GPU's to developer workstations whose primary function was to write code for embedded systems in a text editor and use a terminal for serial console and ssh access. Are you fucking kidding me? Again, mumble, grumble, sweary words but easier to throw money at RAM, SSD's, GPU's and new workstations than to put the time and R&D into retooling my entire companies software platform

    Next came snap packages to replace traditional deb packages. What an absolute clusterfuck. Seriously what kind of idiot thinks its a good idea to ship half an operating system with each software package? This level of abstraction for the sake of stupid "developers" unwilling or unable to learn simple package management tools is ridiculous beyond belief, not to mention the mess it makes by mounting every app at is own loopback device. The wasted storage and RAM went up again as each snap app packaged and ran its own versions of already installed system libraries. The apps didnt integrate properly into the desktops because they ran separate versions of toolkits and themes. Add to that the doubling in average startup times for apps. Only a few to start with and nothing system critical. Even though they were shipping with some snap packages it was a simple enough job to disable snap and use the equivalent and standard deb packages from the repos. Then apps stopped appearing in the standard repos at all, only being available as snap packages. Current versions of Chromium and Firefox could no longer be installed from the standard repos. Canonical told the world a load of bullshit; it was too difficult to build Chromium for multiple releases and therefore snap was the way forward. We (a tiny development house compared to Canonical) were building and maintaining multiple versions of Chromium for multiple architectures including arch's with custom GPU and VPU code required (Pi4/RK3399/RK3288/AML905/AML922/etc) so we knew this was horseshit firsthand

    This was the critical point for us and when we decided to switch away from Ubuntu desktop. Ubuntu Server (sans snaps) is still a great, if imperfect, end product, even the 22.04 release. We still use Ubuntu's core (NOT Ubuntu Core) for the base of some of our embedded systems and for our servers without snap but the Desktop has reached Microsoft's levels of bloatware and multi toolkit stupidity sadly

    I also have a small web design agency (well 50% of it) that is mainly a windows house (with a couple of macs) and to be fair Windows hardware requirements have grown at pretty much the same rate as Ubuntu Desktop. My whine is that there is no real reason for it other than lazy development and the overuse of abstraction layers

    1. yetanotheraoc Silver badge

      Re: The new standard in bloatware sadly

      Entirely agree your points. However, while it's easy to criticise OS makers for favoring their own developers over performance, their problem is real. In fact it seems you stuck with Ubuntu Desktop for so long for a similar reason, so you tacitly agree (at least somewhat) with their reasoning.

      I think the lesson is that in the short run we can get away with taking the easy path, but that path is a trap and gets progressively harder. Eventually there is no choice but to turn back. There is no escape from work. Working hard early keeps things manageable later.

  7. therobyouknow

    Hoping for improving x86 touchscreen tablet support over time

    I'm hoping that there will be improved touchscreen support over time. I'm not sure we're there yet with fully workable support on many x86-64 Linux distros.

    I don't think the touchscreen tablet is an edge / fringe / non-mainstream form factor. After all, iPads and Android tablets have been sold for years now and are quite popular. It does puzzle me as to what people believe a normal mainstream use of Linux should be. See also:

    My answer for use cases of Linux would be: be able to use it for anything that any other OS is used for. Not just sitting in a gaming chair at a desktop one-upping others over what K-this or G-that windows manager they're using! Not just year of Linux Desktop but year of Linux on everything that the end user wants. I used my tablet pc running Windows strapped to my arm going up scaffolding once to collect information. I don't want difficulties with the UI in that situation.

    Some distros claim their OS can do anything that other OS can do: If this is equivalent to how Windows supports touchscreen tablet then that would be a good start but I would be doubtful of that one.

    Explaining Computers did an encouraging video of Linux Mint, based on Ubuntu, regarding touchscreens But when I tried this out for myself on my FZ-G1, there are still some rough edges: launcher needs to stay onscreen when typing on onscreen keyboard. Onscreen keyboard needs to not be overlapped by launcher. Onscreen keyboard needs to be draggable. 2 finger scrolling doesn't work. Onscreen keyboard size setting needs to be the same at login as it is when logged in.

    1. Robert Carnegie Silver badge

      Re: Hoping for improving x86 touchscreen tablet support over time

      On Windows I use the "Fitaly" touchscreen keyboard - and I park it on a fattened taskbar, right side of the landscape screen, or at the foot of the portrait screen. Maybe something like that will work in Linux. A catch in Windows is that the taskbar often puts Fitaly's window behind the taskbar.

  8. Pelican Express

    Some slight hiccups (Gnome version)

    I updated my work machine from 20.04.4, Secure boot, Gnome 3.36.8 with X11 to 22.04.1 Gnome 42.2 with Wayland

    Using the command line method which essentially are:

    sudo apt update

    sudo apt upgrade


    sudo do-release-upgrade

    The upgrade was successful. The most visible change was the switch from Gnome 3.36.8 on X11 to Gnome 42.2 / Wayland. The computer works almost like before. The distro upgrade had disabled some 3rd party repos. Which I fixed by manually uninstalling the app and reinstalling again connecting to the new repo jammy instead of focal. Example: terraform, helm.

    The hiccups I got were minors which I guess were caused by the switch from X11 to Wayland:

    1- Bitwarden (snap app) no longer show up. Fixed by uninstall + reinstall

    2- Firefox, same as above. Except that I installed a non-snap version. Not that I am against snap (I don't mind the slight slow startup), but in the moment of panic, I found a tutorial installing Fixefox As Firefox works OK so I just leave it as is.

    3- The app icons in the top status bar (Slack, Teams, OpenLens, etc.) are all lost. Gnome extension seems to still work because the custom theme is still working.

    4- Flameshot is permanently non-functional

    5- pass requires `apt install wl-clipboard`

    6- ZSH autosuggestions plugin works but the FG color of the suggested syntax is white instead of dimmed gray. This becomes confusing as this gives the impressiont hat you have already type the suggested text.

    Overall the computer is functional, I can works as before startup apps, Git, Tmux, GPG, dev tools seems to work as before.

    In spite of the hiccups, I'd say the upgrade was successful. The above minor issues are fixable or would have workable alternatives.

    Right now I would say that I don't like the Libwaita theme of native Gnome4 apps such as the "text Editor 42.2". It's titlebar is all black not respecting the colored titlebar of the custom theme. Its confusing like hell because when several windows overlap it's hard to tell them apart.

    I think I am going to switch from Gnome to KDE. Currently playing around with KDE on a separate machine. Find KDE more logical, at least suits me better in terms of config. Not sure if this is worth the efforts though.

  9. OldCrow 1975

    Better to be correct.

    Ubuntu has learned finally that is is better to be correct than prompt.

    It took them long enough.

  10. OldCrow 1975

    Better to be correct.

    Ubuntu has finally learned it is better to be correct than prompt.

    Took them long enough.

  11. Henry Wertz 1 Gold badge

    Smooth upgrade

    My upgrade went pretty smooth, upgraded 6 or 7 systems from 20.04 to 22.04 recently. I had to "ppa-purge savoury1/ffmpeg4" to downgrade ffmpeg, mpv, x265, etc., since the newer-than-stock versions that provided "confused" the upgrader. do-release-upgrade actually tells you to use ppa-purge to downgrade, so this isn't something I had to figure out to do myself. I probably should have removed my other PPAs but didn't since do-release-upgrade didn't complain. Smooth sailing after that. As has happened before (probably because of other PPAs...) I did have do-release-upgrade terminate early on one or 2 systems, but after a reboot I could then run "aptitude full-upgrade" (or equivalent from a GUI) and it continued upgrading pacakages and removing obsolete ones. I set up x11vnc for remote desktop, since it does remove the (vinagre) inbuilt vnc server with no replacement (apparently the replacement is planned to be integrated into Gnome 42 and they're using Gnome 41? No worries x11vnc works as well now as it did when I used it before.)

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Other stories you might like