back to article Accidentally wiped an app's directory? Hey, just play the 'unscheduled maintenance' card. Now you're a hero

The oversized rear of Monday is obstructing our view of the receding weekend. Never mind, pour yourself a beverage, select a pastry and settle in for a morning with the Regomiser and another edition of Who, Me? We skip back a few decades this week, to 1990 and the misadventures of "Terry", a student of computer science at a US …

  1. Anonymous South African Coward Silver badge

    hah, did a del *.* in the root of a DOS 3.30 workstation once.

    Fun times.

    IIRC DOS 6.00 and higher will ask you the location of COMMAND.COM if the system booted up and the command interpreter was missing. Not so with DOS3.30 and others, you get the dreaded "Bad or Missing Command Interpreter. System halted" message.

    Which requires trundling off to find a boot disk, boot that up, and copy COMMAND.COM over (plus other gubbins like AUTOEXEC.BAT and/or CONFIG.SYS and other drivers).

    At least it was simple to fix such mistakes back then.

    One more interesting thing to note is that all DOS messages have been formatted for a 40-column screen, due to the existence of CGA monitors.

    1. Korev Silver badge
      Facepalm

      When I was young and only had a PC with DOS on floppies, I had the clever "idea" of copying all data to a RAM disc and then copying back at the end so everything was nice and fast. If you ran out of memory then you'd need to delete a bit - of course I managed to del *.* in the wrong directory and deleted the DOS disc.

      Luckily by this point I'd learnt to not touch the original disc and to only use a copy.

    2. John Robson Silver badge

      Doing chroot development work.

      All the dev boxes were in use - Manager told me to use the build server.

      Couple of days in and I cleared out my chroot jail:

      `rm -rf /bin /usr /etc`

      Yep, I accidentally added the `/` to the start of each path...

      Took me about 1 second to realise that the command was taking too long, by which time most of bin had gone...

      1. Anonymous Coward
        Anonymous Coward

        Hey, it's a rite of passage.

        If you've never done that you've not been using a computer, or lying :)

    3. Doctor Syntax Silver badge

      "all DOS messages have been formatted for a 40-column screen"

      Somehow, as technology advanced, error codes alone grew towards the 40 character mark.

    4. jmch Silver badge
      Facepalm

      Back when I was young and greener than green, it had not occurred to me that while local deleted files went into the trashcan, network deleted files were just gone.

      I learnt that lesson the hard way...

      1. Gene Cash Silver badge

        One thing Novell Netware had going for it was the "salvage" command.

        It marked stuff for purging when you deleted something. When it started running out of disk space, it would start actually removing deleted files. Until then the salvage utility would "undelete" stuff.

        1. JimboSmith Silver badge

          Salvage

          Yes that was very handy thing to have at your disposal. I can't count the number of times I was seen as a "genius" for recovering somebody's accidentally deleted files.

    5. macjules Silver badge

      About 5 years ago I wasn't paying the closest attention to a DevOps trainee who asked me if it was ok to deal with a warning message from AWS regarding a failing instance. I told him to go ahead, which resulted in a terraform script not only terminating the instance instead of just shutting it down, but also releasing the elastic IP address. The good news was that the RDS database was untouched, as was the S3 CDN, so it was just a matter of rebuilding the image, reassigning an IP and updating Route 53 and then to come up with a plausible lie downtime error message. But still a rather nasty moment.

  2. Prst. V.Jeltz Silver badge
    Facepalm

    "to screw up completely requires a computer..."

    On a remote site , i borrowed a colleagues laptop and needed to get / update some files on laptop for the job at hand .

    I thought a Robocopy / MIR might do the trick nicely.

    The thing with /MIR is if you dont get your path exactly right every file in the destination folder becomes the enemy.

    A sinking feeling was rapidly growing as a saw an unexpectedly large amout of deletions scrolling past.

    The thing was ripping through the win\system32 folder like a cancer, gutting the OS.

    After a hasty Ctrl-C the machine managed to stay alive for few minutes like a wounded soldier riddled with bullets, before passing away.

    I was pretty red faced as we knocked off for the day. I bought the after work pints and rebuilt the machine next day.

    1. Julian 8

      Re: "to screw up completely requires a computer..."

      Would have taken all night if that was OS/2 1.3 and then the path diskettes

    2. Anonymous Coward
      Anonymous Coward

      Re: "to screw up completely requires a computer..."

      That's why you should always write to a log and use the /L switch with robocopy. Check the log carefully, then remove /L and run the robocopy job for real.

      1. John Brown (no body) Silver badge

        Re: "to screw up completely requires a computer..."

        ...except when you're in a hurry, screw up and then "lesson has been learned". Bets practice is great when you have the time, but we've all been pressured into getting the job done NOW!!!!!

        1. Anonymous Coward
          Anonymous Coward

          Re: "to screw up completely requires a computer..."

          The few minutes extra is worth it, even with NOW!!! jobs, especially if you are using /MIR or /PURGE.

          I have a standard default set of switches I use with robocopy to ensure I don't get bitten, including /L

          Run the job, CTRL-C after a few seconds, sanity check the log headers then run without /L.

  3. Julian 8

    That would have taken all night if it was OS/2 1.3 and all the patch disks

  4. Sgt_Oddball Silver badge
    Gimp

    The more things change the more they stay the same...

    Recently installed a beta client for a certain game launcher (yes, I have a gaming rig, I've got a few macs and two servers at home. Don't judge me) and discovered it wouldn't start... No problem I'll just uninstall and reinstall...

    Yeah, no...

    This started an hour long tearing through various locations, cache directories and regedit before finding that CC cleaner (I was getting desperate by this point) deleted the recycle bin by default removing a folder I needed for the actual solution (uninstalling via a cached msi).

    Got it sorted with some file recovery magic but still far more buggering around than a game client should ever require.

    Gimp icon because I must be to continue to pay them money for this crap...

    1. Anonymous Coward
      Anonymous Coward

      Re: The more things change the more they stay the same...

      I recently installed a alpha client for a certain game launcher (the free Call of duty thing)

      After downloading 70 gigs the thing just flat out wont run. no errors . just nothing happens, apart from an exe is launched , then closes.

      Perhaps its a sign to stop wasting my life on first person shooty

  5. ColinPa

    short cuts can be bad for your health

    I had a colleague using VM/370 and filelist - where it would display a screenful of files, and you could type a command in front of each filename

    He had E for edit, BR for browse and ER for erase. When the command finished it would change the first letter to * so BR became *R

    I remember watching him, type BR to Browse the file, and realising he needed to edit it, he typed E and the file disappeared. He said "that's strange - it often does that"

    I asked if he used "ER" for erase - and he said "ah yes - that would explain it". I suggested he rename er to ERASE. I was amazed he had never taken the time to find out why his files kept going missing.

    1. andy k O'Croydon
      Coffee/keyboard

      Re: short cuts can be bad for your health

      I assumed this was going to end in an error where E was meant to be typed but ER was by accident, by virtue of those letters being adjacent to each other on the keyboard. Another good reason to make your suggested change. (Icon is keyboard related.)

  6. Rob Daglish

    I seem to remember borrowing a PC (possibly a new-fangled 286!) from school one summer holiday when I was about 8 or 9, and doing some "tidying up"... which possibly involved the use of "format c:"

    It didn't have any immediately deleterious effect until after I switched the machine off if memory serves, at which point it became completely apparent that I'd buggered it up big style - or that's how it looked to me at the time. I think the head teacher managed to reinstall everything from floppies and saved the day.

    I remember that same gut wrenching moment of terror on only one other occasional: I was, for $reasons, merging two NDS trees within a school (one admin and one curriculum). I'd done the merge, and then started updating the ADMIN server from Netware 5 to 5.1 (again, $reasons - it was working fine, I should have left it be...) and somewhere through the install there was an option to either leave the disks as they were or format them. No prizes for guessing what I managed to do! I had backups, so nothing was lost except a bit of extended downtime, and I've learned to read things a bit more carefully since then, which is no bad thing.*

    *Unless you ask me to check a document over, in which case I've a tendency to notice all of those little things you'd rather I didn't.

  7. Neil Barnes Silver badge
    Facepalm

    Late eighties, early nineties maybe... a TV and radio newsroom using Basys to handle all the scripts... ten to six... user needed to be restarted. No problem.

    But it turns out there were two similar commands, one of which restarts a single user and one of which restarts the complete system. Guess which one I remembered?

    Newsrooms are good at swearing, but it all fired up before the critical six o'clock.

  8. Anonymous Coward
    Anonymous Coward

    Ah!

    WordPerfect 5.1 - definitely the pinnacle of word processing. Everything since has added for over function - well I'm an old grouch and that's my opinion!!

    1. Peter Prof Fox

      Word Perfect is still the best

      You'll need WP 8 from 1997 and a virtual Win XP machine.

      When things don't turn out exactly right just look at the embedded codes with a single key. Hey presto!

      I write write a quarter of a million words a year on mine. Don't get me started on the alternatives!

      (If somebody wants to collaborate, then make sure they agree to do all the formatting on Word or Libre Office etc.)

      1. Anonymous Coward
        Anonymous Coward

        Re: Word Perfect is still the best

        You do your writing on an XP emulator in order to use a 24 year old word processor?

        1. Fursty Ferret

          Re: Word Perfect is still the best

          *sniffs*

          If it's not in LaTeX then it doesn't count.

          1. Korev Silver badge
            Gimp

            Re: Word Perfect is still the best

            You forgot the icon... -->

          2. Anonymous Coward
            Anonymous Coward

            Re: Word Perfect is still the best

            My limited experience of LaTeX (which seems good in theory, but I find all those backslashes even more awkward than HTML closing tags) is that as soon as you want to do anything "complicated", like handle Unicode, graphics, hyperlinks, etc, it can all too easily turn into:

            "You are in a twisty maze of add-on packages, all not quite alike, nor mutually compatible."

        2. JimboSmith Silver badge

          Re: Word Perfect is still the best

          You do your writing on an XP emulator in order to use a 24 year old word processor?

          If it was a choice between that and Word for Web I'll take the 24 year old word processor. No grid lines? WTF

    2. Dabooka Silver badge

      Re: Ah!

      I concur. In fact I still use Ctrl-Shift-F12 in Word for the Print dialogue, and I think that was a WP5.1 shortcut if I recall correctly.

      Do you remember those laminated templates that went over the function keys to prompt for shortcuts?

      1. A.P. Veening Silver badge

        Re: Ah!

        The print dialogue shortcut in WP5.1 was <Shift><F7> (and that is the only one I still remember).

        1. Dabooka Silver badge

          Re: Ah!

          Thanks for that. I wonder where Ctrrl-Shift-F12 was from? I'm certain Word was always Ctrl-P (that includes the DOS versions). Maybe I'm wrong.

          I'm probably wrong. I'm usually wrong.

          1. J.G.Harston Silver badge

            Re: Ah!

            Shutdown.

    3. bigphil9009

      Re: Ah!

      If only it had added some sort of grammar checker ;-)

    4. MJI Silver badge

      Re: Ah!

      I prefered WordStar myself.

      1. John Brown (no body) Silver badge

        Re: Ah!

        Same here. I first used it on 8-bit CP/M and stuck with it through CP/M-86 and MS-DOS until that abomination of WordStar 2000 came along and it's bastard cousin WS1512 for the Amstrad PC1512 :-)

      2. Anonymous Coward
        Anonymous Coward

        Re: Ah!

        On the plus side, you can STILL use the cut/paste shortcuts. Amazing how they persisted over the years decades.

  9. Evil Auditor Silver badge

    Accidental deletions are more common than management realises.Really? [Fill in Eastern European expletive of your choice]

    It's not exactly what I call «accidental deletion» but deletion nevertheless: for at least a half a year we have recurring situations with Microsoft Word and Excel files. You open the file again after someone else edited it and what you see is your last version but not the other persons' more recent changes. Lucky you if you notice the issue.

    Don't know if its Sharepoint or the Office suite or something else and neither do I care. It's just a bloody cock-up.

    1. Dave314159ggggdffsdds Silver badge

      It's a cock-up, alright, given that it's an admin error. Get the people responsible to set the default revision tracking settings correctly. Someone must have deliberately screwed around with them to cause that issue.

    2. Anonymous Coward
      Anonymous Coward

      I'd go for Sharepoint and someone starting to update file but wandering off and their laptop going to sleep

      ('but I distinctly remember updating that file yesterday with the stuff that went missing last week!)

      1. blah@blag.com

        I was once sent a presentation about the new shiny feature set of Sharepoint 2007 to assess for company use. I sent it back with a slight edit of the title page changing "Sharepoint 2007" to "Lotus Notes 1997".

      2. imanidiot Silver badge

        Sharepoint deserves to get taken out back and shot imho. No love for that system from me as a user. At all.

  10. heyrick Silver badge

    accidental deletions are more common than management realises.

    And yet so few systems have an easy way to undo an accidental deletion.

    Android phone plugged into PC. Copying my photos across to make space on the phone and back up to DVD. Was doing them in batches of 100 (easy to spot if anything was missed, for some reason there's always one or two that don't get copied over).

    Checked, double-checked, that 100 is good. Hit Delete. Blindly click on the OK message.

    And promptly shit my pants when I realise that the highlight was in the other half of the window, and I'd just nuked the entire DCIM folder.

    .

    .

    Thankfully I had a full system backup of two weeks prior, so nothing of importance was lost. But in between hitting OK and remembering the backup, I swear I aged an entire year.

    There ought to be an "Oh Shit" button that can undo the last command given. Wipe /usr by mistake? Hit the Oh Shit button. Delete all your photos? Oh Shit them back again.

    [before anybody suggests, no, I don't spew my photos to a foreign cloud based service]

    1. Gene Cash Silver badge

      Re: accidental deletions are more common than management realises.

      Wasn't there some OS (BeOS??) where the filesystem was actually a database, so the "oh shit" button was the equivalent of a transaction rollback?

      I'm getting too old to keep track of all the cool shit that was completely abandoned. I believe it was because it was too slow and they didn't have the CPU horsepower to throw at it.

  11. JulieM

    VAX/VMS solved this years ago

    I was at uni in the early 1990s, and VAX/VMS had versioning baked into its file system.

    Why Microsoft did not bring this obvious feature into NTFS when they had Dave Cutler working for them will always be a mystery to me.

    1. KLane

      Re: VAX/VMS solved this years ago

      I remember that Novell Netware, probably from version 1.x, had a network recycle bin. It took an admin to access/restore from it, and even tracked who did it, IIRC.

  12. Andytug

    Be very careful where you click...

    Once when fixing a shared folder permissions issue, nice and easy, right click folder, permissions, reset permissions on child objects, job done.

    .....except if you have accidentally highlighted the workgroup folder for the whole office, not the single folder at the top that you actually wanted to reset.

    Correct folder resets, then it started on the next one......ohsh!t moment. Frantically cancelled out of it....after 5-10 seconds of terror, and it had only got part way through folder 2, which fortunately had no special permissions or structure under it.

    Step away from the computer.......slowly. Get drink, calm down. Resolve to be more careful in future.

    1. Gene Cash Silver badge

      Re: Be very careful where you click...

      > accidentally highlighted the workgroup folder

      M-----F----- stupidass GUIs. I'm about as coordinated as a 6mo baby on Jim Beam, so GUIs constantly screw me. "No goddamnit, that was a double click, not a triple click!"

  13. spireite Bronze badge

    'Unscheduled maintenance' - your qualification for IT roles.

    Let's face it, if you've worked in IT for more than 2 years, and not 'played' the UM card, you don't really work it IT... do you??

  14. pstones578

    Accidentally deleted some VM's once

    In my defense, we had been pressured to move a project along even though we did not have enough storage, so we hosted the VM's on local storage on a host. We forgot they were there then one day rebuilt the host as it was playing up and it's quicker to rebuild and join the farm than waste time troubleshooting. It soon came to light the 2 VM's on the local disks have gone off the network.... Fun times!

    1. spireite Bronze badge

      Re: Accidentally deleted some VM's once

      I see Docker containers disappear into the ether regularly, nobody ever held their hands up, even now.....

      To quote Shaggy.... "It wasn't me"

      1. earl grey
        Trollface

        Re: Accidentally deleted some VM's once

        To quote scooby: RUH ROH

        (i know, i know...but it IS appropriate)

  15. aerogems

    Reminds me of the old joke

    Or maybe it's more of an anecdote.

    It's Bob's first day on the job and he's ready to hit the ground running. A call comes in, Bob rushes off to deal with it, and in the process ends up causing $10,000 in losses for the company. Bob slinks back to his desk and is almost done with his resignation letter when his boss turns up. Bob tells him not to worry, he's writing his resignation letter now so there's no need to fire him. Bob's boss looks at him with a puzzled expression and asks, "Why would I fire you? I just spent $10,000 on your training." Change that to the currency of issue for your location if desired.

  16. J.G.Harston Silver badge

    Been there, done that

    Something does SET TMP=C:\APPDIR

    Then something else does

    WIPE %TMP% /YES /RECURSE /QUIET

  17. Huw D

    Add end users, stir vigorously

    Let's say there's a network folder named S:\Department\Project and it contains Excel, Word and Powerpoint files...

    User1 realises that if they open that folder in Excel, they only see Excel files. If they open it in Word they only see Word files, etc.

    User1 also realises that if they change the filter to "All Files" they can see (obviously) all files and mentions this to User2.

    User2 does this and then gets confused. So because they don't want to see Excel files when they're opening files in Word, they DELETE the Excel files.

    User3 then logs a ticket asking where the Excel files have gone...

    1. John 110
      Angel

      Re: Add end users, stir vigorously

      I learnt not to assume that end users know *anything* about the PC you've just given them when I gave a new medic the PC that had belonged to their predecessor. I told her that all the guy's stuff should have been on the network so delete anything you don't recognise... She deleted the Windows directory.

      I didn't want to tell IT because they were a bunch of grumpy sarcastic buggers. That's when I learnt to restore Windows XP from the recycle bin...

      1. Huw L-D

        Re: Add end users, stir vigorously

        (un)luckily, I was only called in to sort out the mess.

  18. Anonymous Cowerd

    Happy memories

    Happy memories of joining an Oracle team as the newbie.

    My "trainer" decided to show me how much authority he had by logging on to a test database and deleting a cross-reference table. As he proudly showed me how nothing would now work in the application, the phones started ringing.

    As you might have guessed, he was actually in the production system.

    It was passed off as a network problem while the table was restored from a backup.

  19. Stuart Castle Silver badge

    Couple of stories here. One was me, one wasn't.

    The first was a few years back, I was setting up Windows again. I do this from time to time whether it needs it or not, as it's a good way to ensure that I get rid of unnecessary files and application. When I do this, I only re-install applications if and when I need them. I have few HDD partitions full of different applications and data. I planned to delete my Windows System partition, recreate it and install windows on the now blank partition. I got to the page in the Windows installer that enables you to delete and recreate partitions. While I was doing this, a housemate walked in and start talking. All of a sudden, I wasn't really focusing on what I was doing, so I happily selected the wrong partition, deleted it, recreated it and installed Windows on it. I only realised when I found I had two Windows installs. I lost quite a lot of data, thankfully, none of it really important, so it was a pain in the arse rather than a real problem.

    The second, I got from someone else. A friend worked for a small budget games developer and publisher. He told me a story about his boss, who accidentally went to the C:\Windows folder on his machine. This was Windows 3.1, so there was no protection, and when he did this, he called my friend to try and retrieve the contents of the machine. The problem was, his boss had installed every application to this folder, and put all his data in it. I think my friend managed to recover some of the data with an undelete tool, but only some.

  20. aregross

    Didn't PCTools have an undelete function?

    ...and I still have a WordPerfect 5.1 key board template that layed on top of the function keys. I lost the one from the original IBM keyboard where the function keys were in two rows on the side of the keyboard, not above the numbers.

    http://www.edugeek.net/attachments/forums/general-chat/36177d1460558438-computer-brands-graveyard-wordperfect-5-0-keyboard-template-top.jpg

    1. John Brown (no body) Silver badge

      "Didn't PCTools have an undelete function?"

      If you caught it before the file space got overwritten, you could easily undelete in MSDOS. The action the OS took to delete a file was simply to set the high bit of the first character of the filename so it was pretty simple to undelete by just resetting that bit back low. At a pinch, you could do it with DEBUG in the root directory. It could be a bit more tricky to do so in sub-directories, so one of the many undelete tools that could identify and follow the linked list to sub-dirs was a lot simpler.

  21. aregross
    Happy

    Oh and to the point of the article... If you thought del *.* was bad, try deltree *.* from the root... Ding! Empty Disk!

    1. John Brown (no body) Silver badge

      DELTREE didn't appear until MSDOS 6.0. Pah, kids today! Don't know they're born. In my day, you had to go into right to bottom of the tree and start doing DEL *.* one directory at a time, working your way back to the top before you could cause that much damage. And do they believe you? 'course not!

      Now git orf ma lawn!

      1. spireite Bronze badge

        So, i guess you use the TRIM function regularly now!

        1. John Brown (no body) Silver badge

          I use the super version, STRIM :-p

    2. Anonymous Coward
      Anonymous Coward

      Just had a couple of Cisco routers where someone's attempt at deleting the config appears to have been to format the flash... except the config isn't in that portion of the flash and all they did was to delete the IOS.

      I power the router on and it just keeps cycling through looking for the specified IOS, not found, looking for ANY IOS, not found, reboot the hardware. I try to break in to the loop and it responds 'Y to delete config' (NO PASSWORD RECOVERY has been set). I hit Y and it just reboots because the 'delete config' routine is in the IOS that the router can't find!

      I ended up borrowing the flash module from another (working) router just so I could boot an IOS and could then start changing boot options so that I could boot the sod from a USB stick and reinstate the original flash module

  22. John H Woods Silver badge

    When SHIFT sticks ...

    Went into my big flat project directory, 30 years ago and decided to delete all my intermediate object files to free up some space. rm *.o became rm *>o and I got quite a bit more space back. Just left with a little file called o containing a single linefeed.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2021