back to article Cortana makes your PC's heart beat faster: Windows 10 update leaves some processors hot under the cooler

Some Windows 10 users are experiencing alarming CPU spikes following last week's optional cumulative update. The problem patch, KB4512941, was released last week as a update for Windows 10 1903 (aka the May 2019 release.) While optional and not a security update, 1903 was still an important patch and contained a bunch of …

  1. ashdav

    Agile !

    It's the future !


    1. ecofeco Silver badge

      Re: Agile !

      And "Microsoft" is the opposite of agile!

    2. bombastic bob Silver badge

      Re: Agile !

      FRAgile you mean

      1. Paul Herber Silver badge

        Fragile !

        good album, that.

    3. Anonymous Coward
      Anonymous Coward

      Re: Agile !

      Waiting for Argyle programming to become a thing, followed shortly by the vastly superior Gargoyle programming. Obviously better because it has more letters. Of course, many will feel it too heavy and opt instead for Gargle programming.

    4. This post has been deleted by its author

      1. Midnight

        Re: Agile !

        Thank you for coming to my TED talk.

      2. Paul Herber Silver badge

        Re: Agile !

        I think that needs a flowchart.

  2. NonyaDB

    Microsoft Patch Engineer over the holiday weekend...

    "Go 'way. 'Batin'."

    1. ecofeco Silver badge

      Not enough upvotes.

  3. Anonymous Coward
    Anonymous Coward

    Not concerned.

    It's the first thing I disable as early as possible in the installation/configuration process. The day Microsoft will try to prevent me from doing this I'll just quit using Windows (at home of course). I'm not a gamer or a Photoshop power user so there's nothing to keep me attached at the back of the Microsoft wagon.

    1. Blackjack Silver badge

      Re: Not concerned.

      Why aren't you using Linux Mint or some other desktop user friendly Linux distro already? Yes things can go wrong on Linux but usually not to the lengths Windows 10 updates do.

  4. Anonymous Coward
    Anonymous Coward


    From reading the comments left on Reddit it appears that it only happens if the user has disabled Bing from Cortana search.

    "Fix is to reenable Bing search in the start menu and reenable Cortana if disabled (then restart)."


    And this:

    "t’s a bad news because this setting allows cortana to use web results for the search.."

    "I hope Microsoft will correct this problem because we don’t need to use internet resource to search a file in the pc…"



    Remember when Unity Linux tried to pull this crap years ago?

    Richard Stallman called it akin to spyware. (And rightly so)

    1. veti Silver badge

      Re: Bing!

      Remember the 90s, when Microsoft totally missed "this web thing" and the threat it posed to their business model?

      Yeah, well they do. And when they woke up, circa 1998, they resolved that from now on everything they did would have "web" built into its very bones. This is the after-effect of that awakening: they now have trouble even recognising that a client PC can exist as a physically distinct machine.

    2. rmullen0

      Re: Bing!

      Re-enabling Bing didn't work for me. I tested it the day before an updated patch came out and it didn't work. I got burned on several computers with this bug. Others were fine for no apparent reason. It appears that they removed the option to disable Internet searches through the search box in recent versions of Windows 10. I ####ing hate Cortana. Looking forward to more people switching to other platforms. Microsoft deserves it for all the years that they have forced this #### on us. It is one annoying feature that you didn't want after another. They should stick to core OS features and not try to parrot Apple and force it on you. All the new features are a massive privacy violation. Especially things like Timeline. And then of course they have it upload everything to the cloud. It is ridiculous.

  5. ridley

    Killed my audio..

    Still not got it working again, even after uninstalling what I can

    1. fobobob

      For a quick workaround, if you've already tried uninstalling the audio devices from Device Manager and let it Plug'nPray, a cheap USB audio dongle might do the trick. Might also make sure Windows Audio and Windows Audio Endpoint Builder services are even running.

      1. Midnight

        Or you could install Linux for its superior audio support.

    2. rmullen0

      If you have System Restore enabled, you can do a System Restore to undo the changes. Restore to a restore point before when you installed the update.

  6. Joe User

    A novel concept: don't ship until it's ready

    The sleuths over at Windows Latest found the issue also reported in Microsoft's Feedback Hub for the Windows Insider Preview Ring, but no action was taken before the update was unleashed on the wider world.

    When the deadline arrives, Microsoft pushes the updates out the door, ready or not.

    The spice must flow! Er uh, the code must ship!

    1. Mark 85 Silver badge

      Re: A novel concept: don't ship until it's ready

      You forgot... "testing.. we've heard of it but that for the users to do."

  7. Ringstop


    1. diodesign (Written by Reg staff) Silver badge


      Brit speak for vacuuming


      1. Hemmels

        Re: Hoovering

        In only the same way people bathe in "jacuzzi"s instead of hot tubs.

      2. Tom 7 Silver badge

        Re: Hoovering

        Toobing? Or shouting at the maid?

  8. Nolveys

    They recently integrated Tay.AI code and the increased CPU usage is the system recognizing and suppressing hitler-loving, racist, incestual sex-crazed rants. Luckily the feature they really needed, "zero chill", works perfectly.

    Whatever you do, don't ask it to describe only the good things that come into her mind when thinking about her mother.

  9. steviebuk Silver badge

    Disable it

    I've put in a group policy to disable it on all machines and avoiding 1903 anyway so hopefully won't see it.

    Can also disable it via cmd

    REG ADD "HKLM\SOFTWARE\Policies\Microsoft\Windows\Windows Search" /v AllowCortana /t REG_DWORD /d 00000000

  10. Hubert Cumberdale Silver badge

    My processor was at 60%...

    ...I thought it was just rebuilding the search database or something, but it just would not stop. And my start menu search was also utterly borked (just a black panel). Tried all the workarounds, some seemed to help briefly, but it kept coming back. Ended up doing a full re-install keeping settings, still no joy. Was the last straw I needed to make me finally surgically remove Cortana and install Open-Shell. The search actually seems better, if I'm honest.

    As an aside, some sources seem to report that it's particularly a problem for people using German as a Windows language. That fits with me. Oddly, though, it only happened on my laptop and not my desktop. In any case, I've now murdered Cortana. Weirdly, I feel slightly guilty about it. Maybe it's pity.

    1. bombastic bob Silver badge

      Re: My processor was at 60%...

      I noticed a REALLY long time ago that Win-10-nic (paticularly UWP and 'The Meto' CRapps) was a CPU waster. Often (running in a VM) during startup I'd see two or more of these CRapps attempting to communicate with each other (including the 'start thing' and presumably search and Cortana), only to SPIN on CPU utilization at 100% while wasting wall time.

      I tracked it down (somewhat anecdotally, some experimentation) to the use of 'instantly returns' timing on synchro resource checks and polling of some kind, things that are supposed to put you into an IDLE wait state while waiting, but don't.

      Specifically, like WaitForObjectEx with a 0 timeout... or Sleep(0)... or 'yield()' calls. DECADES ago I discovered that if you have a polling loop (including message loops that do background things) you can NOT specify a 0 timeout, or you'll spin at 100% CPU usage.

      For UWP and Win-10-nic "they" apparently stopped using a standard message loop, and apparently use something inside ".Not" or a UWP core of some kind. THIS is where the problem is!

      /me points out that THIS problem was solved by ME decades ago, for Windows '9x even, 2k had the problem, XP a bit less so, and it re-surfaced with UWP/Metro CRapps because "our turn now" and they POOCH SCREWED IT.

  11. AnotherBoringUsername

    Screwed two of my machines

    Installed the update on two of my machines.

    It broke both of them.

    Registry change relating to Bing fixed one.

    Other still broken despite any registry changes.

    Pretty poor show from MS.

    1. ecofeco Silver badge

      Re: Screwed two of my machines

      This is NORMAL for MS.

  12. Whitter


    Is Cortana still a thing?

    Is Bing still a thing?


  13. wyatt

    I tried installing 1903 on my work laptop yesterday, it failed. Think I'll avoid it for a bit longer and ignore the almost out of support messages.

  14. BGatez

    Cortana is beyond doubt, the worst POS spyware resource pig there is, and even more detestable than clippy.

    If, unfortunately, your eyesight is so affected that you need to use it you'd still be better off with a talking dog.

  15. LeahroyNake

    Even more broken

    Had anyone else noticed that typing in the search box sometimes returns very random results? If you then delete the search and type it again the thing you were looking for the first time shows up at the top of the list.

    It can't be that hard FFS, I have launched that application 5 times already today!

    1. Captain Obvious

      Re: Even more broken

      Yes - want the remote desktop app? Comes up randomly and not all the time when you do a search. This is why I go back to execute .cpl

      Can also query how to join a domain and find web references and not where they moved the setting for it....AGAIN. Windows 10 ===== PURE GARBAGE

      1. fobobob

        Re: Even more broken

        Know your CPL files! Winkey + R to execute:

        appwiz.cpl (add/remove programs)

        main.cpl (mouse! why? don't know, but it is now. or invoke like "control mouse")

        ncpa.cpl (network adapters)

        sysdm.cpl (old "system properties")

        firewall.cpl (basic firewall config)

        Know your MMC files! WinKey + R to execute:

        devmgmt.msc (Device Manager)

        diskmgmt.msc (Disk Manager)

        services.msc (Services Manager)

        lusrmgr.msc (L(ocal)user Manager for WinPro elites; no Home plebs)

        wf.msc (advanced firewall config)

        compmgmt.msc (Computer manager, basically all of the above)

        Know your other handy stuff! WinKey + R to execute:

        mstsc (Terminal Services / RDP client)

        inetmgr (IIS manager)

        control (control panel; can also do:)

        control mouse

        control userpasswords ("modern" user manager)

        control userpasswords2 (old Win2K era user manager)

        There's a bunch of this stuff, and it's a hell of a lot more convenient than fumbling through Windows Settings:

    2. rmullen0

      Re: Even more broken

      Yes, I have noticed the same thing. It is extremely annoying. Type "updates" one letter at a time to find "Check for updates". Now, backspace/delete the "s" at the end. Now it comes up. The results are inconsistent between multiple computers that I have. I think it may be some kind of timing related issue. The problem seems to appear more on lower powered PCs that I have.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Other stories you might like