back to article Intel finally emits Puma 1Gbps modem fixes – just as new ping-of-death bug emerges

More than 18 months after the design blunder was first brought to light, Intel is still working to iron out the creases in its Puma high-speed broadband modem chipsets. In recent weeks, Chipzilla quietly put out an advisory as well as finally confirming a formal CVE entry – CVE-2017-5693 – for the security vulnerability. When …

  1. conscience

    Same old from Chipzilla

    Intel making something that worked correctly would be bigger news. All I can say is that it is a good job they are good at marketing, what with the flood of articles around the net at the moment that talk about their "superior 10nm process lead"... that all fail to mention that it's only seen a very limited release because it doesn't actually work properly yet. Jim Keller appears to be their only hope for designing something that actually works as intended.

  2. Chris Stephens

    Nice story

    As one of the people who found these issues and has worked tirelessly on this issue I really appreciate El Reg doing such a good job covering this. It has helped put pressure on Intel/ISPs/Modem vendors to get this all resolved.. The real issue is that firmware can ONLY be updated by the ISP. This 1970's era rule needs to go away and CPE needs to be able to be updated by users as well, like cell phones can be updated. PLUS of course Intel needs to completly redesign its "connected home" modem chip from the ground up. I operate a web site with a list of the modems effected..

    1. Tom Chiverton 1

      Re: Nice story

      Users can't update their mobile phones. Almost all Android are locked (and all iOS ones)

  3. Stormy

    So are Intel saying the chipset only has problems when a malicious attack is occurring against it?

    This isn't what all the Virgin Media users were seeing, or were they all under attack at the same time, all the time?

    1. The People

      YES, Virgin Media UK use the puma chipset in their cable modem. There is a Well known bug that virgin actually praise due to its ability to provide the rotten to the core company with plausible deniability if push comes to shove - of all culpability for slow speeds to its customers - so they maintain their modems with the chipset deliberately as a ruse.

      Every single Virgin Media Hub 3 modem will have this issue, where single threaded network connections will suffer massive drops in speed.

      A quick search on google will give you thousands of reports and plenty of technical deep dives into what Virgin are doing to humans, the man at the top is in league with Barack Obama et'al, need we say more.

      AVOID Virgin. Possibly one of the worse companies in the UK, bar none.

  4. jms222

    Virgin Media Hitron

    Recently moved from Virgin Media residential to Business "Essentials" because the latter is cheap especially for the VAT registered (otherwise shit).

    As part of backing up I shunt some data over the (wired) network through the router for the simple reason that it's there and avoids having other switches powered up. With my old Super Hub (model 1) the rate was about 120MB/s as expected. Did the same at the weekend through the Hitron CGNv4 thing and got half of that with gaps of several seconds with almost zero rate. Same procedure with the same equipment as before otherwise. Tried some pinging and noticed _some_ pings taking several milliseconds. So I wonder whether the wired side is not (like) a switch chip as one would hope but maybe goes through the Intel rubbish.

    Also after the slight rain we had last week (and I do mean slight here in East Anglia) the connection went for a whole day and after the main external fix even a soft reboot of the thing did not recover it and I had to power cycle. So much for the many 9s availability they quote.

  5. Dieter Haussmann

    Even under normal use (not attack) this chip is just garbage - massive latency times and frequently runs out off puff and collapses.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Other stories you might like