back to article Apple's magical quality engineering strikes again: You may want to hold off that macOS High Sierra update...

An increasing number of Mac loyalists are complaining that the latest desktop operating system update from Apple is killing their computers. The 10.13.4 update for macOS High Sierra is recommended for all users, and was emitted at the end of March promising to "improve stability, performance, and security of your Mac." macos …

  1. Anonymous Coward
    Anonymous Coward

    countless issues

    many issues with 3rd party software and hardware. to name a couple that I've hit, SQL operations studio can no longer connect with TLS/SSL (to be fixed on 24th IIRC) and pluggable USB laptop port expanders cannot have a 2nd displayport screen - the 2nd screen is now just a mirror of the laptop screen (no known update time)

    however, you cannot just 'not upgrade' due to the security fixes etc in the upgrade. want to be vulnerable just to run some software/hardware - you're going to have to make a decision based on risk there.

    1. James O'Shea

      Re: countless issues

      I can just 'not upgrade'. The machines in question won't be connected to a network which connects to the Internet, and no USB or whatever devices which have not been checked out will be allowed. I have a number of ancient machines sitting on their very own little network, locked away from the outside world, and have had them for a Very Long Time(tm). My beige G3 currently runs 10.2. (Yes, 10.2. Not 10.12. 10.2. I put 10.3 on it once. Bad Things(tm) happened, so I removed 10.3 and put 10.2 back.) I suspect that it would be a Bad Idea(tm) to connect it to the Internet, if only because the only web browsers I have for it are Internet Explorer 5.something and some ancient version of OmniWeb. There have been just a few changes on the Web since those were current.

      Just disconnect the machines from the network. If you can't do that, _then_ you have a problem.

      1. Anonymous Coward
        Anonymous Coward

        Re: countless issues

        "Just disconnect the machines from the network. If you can't do that, _then_ you have a problem."

        Most people only have 1 desktop or laptop and never connecting it to the internet is generally not an option if they ever want to download software, upload work, search for answers or send emails. And thats before you get to trivial stuff like social media and youtube. Yes, in theory you *could* work on a disconnected machine, put everything on a USB stick and head off down the nearest cybercafe (are there any left?) but I very much doubt anyone who values their time will be prepared to do that.

      2. Shufflemoomin

        Re: countless issues

        Why do you have any web browsers on machines you claim are "on their very own little network, locked away from the outside world"?

        1. Jeffrey Nonken

          Re: countless issues

          Came with the OS install.

        2. TheTor

          Re: countless issues

          [quote]Why do you have any web browsers on machines you claim are "on their very own little network, locked away from the outside world"?[/quote}

          To render HTML documents? They don't have to exist on the internet you know!

          (Yes, I know, a minor use case, but possible. A number of software installs give help docs in HTML format).

        3. James O'Shea

          Re: countless issues

          Because they used to be on networks connected to the Internet, a very long time ago, and I've never bothered to delete them as they don't take up much space and I simply don't give a damn. Why do you care?

    2. JohnFen

      Re: countless issues

      "however, you cannot just 'not upgrade' due to the security fixes etc in the upgrade."

      Sure you can, and still maintain relatively good security. You just have to use other security measures.

      This business about upgrades being "not optional" because of security is taking us down a very, very bad road, in my opinion. The decision is not as stark as the companies like to present, because there are multiple ways to maintain security.

    3. Stuart Halliday

      Re: countless issues

      Which is why you have in-house Beta Testers and out-house Beta Testers.

      The only trouble with out-house testers is unless you're very careful, you end up with a load of folk more concerned with One-Upmanship Status with their friends and they can't be bothered to do any real testing.

      Surely Apple hasn't fallen for this old trick?

    4. Mark 65 Silver badge

      Re: countless issues

      High Sierra is looking like Apple’s Windows ME. From what I have read on here and other sites it has been a monumental hubris filled fuck up from start to finish. Even though he could be “you’re holding it wrong” arrogant, I do not believe shit like this would have been tolerated in the latter part of Jobs’ reign.

      Apple may be cash rich but it seems like there are some serious problems emerging - is the quality control a reflection of a cultural malaise?

  2. TWB

    No issues here

    But I am not doing very adventurous stuff....The upgrade went fine, as far as I can remember.

    1. David 132 Silver badge

      Re: No issues here

      For what it's worth, no issues here either - happily running 10.13.4 on a mid-2011 iMac (6 years old! Still perfectly useable! can't get my head around that...) and an Intel NUC5i5MYHE Hackintosh. No, I'm not disputing that some people out there are having problems, but let's be clear that it's not affecting everyone.

      Re the warning-about-deprecated-32bit-apps thing... amusingly, System Report->Applications reports that half the non-compliant applications on my machines are from Apple themselves. And I don't mean in the sense of ancient-versions-of-Keynote-or-iTunes... it's kernel tasks & background daemons that are still 32-bit.

      1. Steve Davies 3 Silver badge

        Re: 32bit apps

        The only remaining 32bit apps on my two MacBooks (2012 and 2015) are from Drobo and Adobe neither of whom seem remotely interested in moving to 64bit apps.

        Yes, I am running 10.13.4

      2. Updraft102

        Re: No issues here

        happily running 10.13.4 on a mid-2011 iMac (6 years old! Still perfectly useable! can't get my head around that...)

        Moore's law is at least in a coma, if it is still alive (at least in the manner in which it is usually interpreted). I have not been keeping up with transistor counts, but the days of a reasonably current PC being worthless a year or two after it is purchased (by means of obsolescence) are well behind at this point.

        I'm reading/writing this from a desktop PC whose motherboard also dates from 2011 (Sandy Bridge/Cougar Point). I have no plans for upgrade at present, and if I did, it wouldn't be about the actual performance of the CPU/RAM/PCH themselves, but about the desire for things like USB 3.1 or a M.2 slot without having to worry about addon cards. I use a single discrete GPU that doesn't even come close to saturating the PCIE bandwidth I have now, and I don't predict that changing anytime soon either.

        My main laptop (which sees about as much daily use as the desktop) was manufactured in 2008, and originally came with Vista preinstalled. The desktop, being originally shipped as parts, didn't originally come with any OS.

        Both machines are perfectly usable right now, despite their age. Both are dual-boot setups with Linux Mint 18.3 Cinnamon and Windows 8.1, 64-bit all around.

        Now, if your comment was about the fact that a machine that old is able to run the newest version of the OS... well, I am running the newest release of Linux Mint, which is where I spend most of my time, and as for Windows... the reason my machines remain perfectly usable is that they lack Windows 10, which is perfectly worthless.

        For the record, I did try 10 on both of these machines, and it worked about as well as 10 could be expected to run... no bluescreens, performance issues, or glitches occurred. The problems I had (and have) with Windows 10 are the things it does on purpose.

        For the first time since I bought the laptop in 2008, I bought a new PC in the last two weeks of 2017. Came with 10, now running Mint like its stablemates. Despite being over nine years newer, it's far slower than the 2008 laptop in CPU speed, GPU speed, disk speed, and the amount of RAM. The screen resolution on the newer laptop is lower, and it lacks the swappable battery and the touchpad with discrete buttons (which I prefer to multitouch any day).

        What the new one does have as a definitive advantage is that the built-in battery lasts all day, while the ten year old laptop manages to exhaust its swappable battery in well under three hours of light use. Sure, I can swap the battery (and I have several, so I can), but by the time I get done hauling the laptop itself (which is not really all that thin and light in the first place) and lots of batteries, I'm too tired to use the laptop anyway.

        It still amazes me that my newest PC is also my slowest. Even though it is definitely low-end and neither of my main machines were low-end in their day, just the fact that a ten year old machine has any relevance at all is something quite remarkable to anyone who remembers the frenetic rate of improvement of PC hardware through the 90s.

        1. WallMeerkat

          Re: No issues here

          "anyone who remembers the frenetic rate of improvement of PC hardware through the 90s.

          Ah yes, a nice 486, then a year later Pentiums are all the rage, couple of years and it's Pentiums 2s then graphics cards, RAM doubling every couple of years.

          Does seem to have slowed down - have we reached a point where we have saturated what we can do with an x86 silicon chip? Have the manufacturers lost interest and switched focus to tablets? Are humans just not able to write software for faster and faster machines to eek every bit of power?

          1. Stuart Castle Silver badge

            Re: No issues here

            I don't think things have slowed down. I think there are two reasons here..

            1) The improvements don't seem as massive. I think this is more that in the 90s, we were going up from 100MHz to 200. 200 to 400. 400 to 700. There are all doubling the speed, or nearly doubling it. Nowadays, speeds are in GHz, and are going from (say) 2Ghz to 2.5Ghz, or 2.5 Ghz to 3, 3 to 4 and so on. We aren't generally doubling the speeds or tripling the speeds.

            2) We don't need that much processing power. With the exception of Games and certain specialist software (3d Modelling, hacking, Digital audio and video editing for instance), most software comes nowhere near using the full power of even a low end CPU. This wasn't the case in the 90s, where even simple word processing could bring the CPU to a halt.

            Note: I'm not talking about server applications, or databases, as these can frequently use a ton of CPU time, but your average computer is now way more powerful than your average punter needs.

        2. casinowilhelm

          Re: No issues here

          Well, since AMD finally got their arses in gear last year and challenged the lazy/greedy intel gits by releasing ryzen/threadripper, we finally got a decent jump in performance again provided you are running multithreaded apps. For an average punter who isn't 3d rendering etc, these advances aren't that noticeable as single cores haven't got all that much faster since about 2012 (at least not in line with the old pentium days).

          FWIW my new threadripper is about 2x faster at rendering than my old intel 8 core 5960x for a bit less money, but it took >2.5 years rather than 18 months for it to come along. That 8 core was about twice as fast as the sandy bridge quad core it replaced, but there was 3 years in it again and it cost more than double the amount (and is actually slower at single threads). So moores law had definitely broken at that point.

    2. ChrisCabbage

      Re: No issues here

      No problems so far for me. I'm mainly running DAW applications (Cubase and Ableton), for what it's worth.

      1. Alperian

        Re: No issues here

        Well as far as DAWs goes, Propellerhead's Reason is putting this out:

        "It has come to our attention that Reason does not work properly under the latest macOS High Sierra 10.13.4 update. Currently, we do not recommend you to update your macOS High Sierra to 10.13.4 if you rely on using Reason, before we have fixed this.

        We’re investigating this issue right now and while we currently don’t have a solution, we hope to get to the bottom of this.

        If you have already updated to macOS High Sierra 10.13.4 and are experiencing performance issues, try deactivating the “Use hyper-threading audio rendering” function in Preferences – the General tab. This might improve the performance in some cases."

        1. ActionBeard

          Re: No issues here

          Thanks for posting this - I have recently installed Reason on a MacBook and have been trying it out.

    3. Charlie Clark Silver badge

      Re: No issues here

      No problems here but it was a monster update and took quite a time to install.

  3. anthonyhegedus

    It's not just USB laptop port expanders that have trouble with second screens. Apparently the update allows you to add external GPUs via the displayport 3(?) connection and in the process breaks things relating to second screens. Such as the Duet app, which allows you to use your ipad as a second screen. They've done a workaround, which is a bit dodgy, but it works, sort of. It's not good enough though, and there's no word from Apple about this at all. Duet are just telling annoyed customers to get in touch with Apple.

    1. Davegoody

      It's THUNDERBOLT 3

      Not........ DisplayPort 3

      1. anthonyhegedus

        Re: It's THUNDERBOLT 3

        Ah thanks, I always get mixed up by these apple things. At least I didn't say Centronics Parallel Port.

        1. Joe Gurman

          Re: It's THUNDERBOLT 3

          Not an Apple thing, but an Intel thing.

  4. doublelayer Silver badge

    This is getting really annoying

    I have had no successful updates since high sierra came out, which has introduced a bug that is seemingly impossible to fix--namely that one of my machines has entered a loop of bricking and unbricking itself. This persisted even after I rolled back to 10.12 and 10.11 so I presume a firmware problem is causing this distressingly-named "SleepWakeFailure". Even when the updates worked, I've seen machines wobbling their way through basic workloads that were formerly fine, as one of the major benefits of OSX is that it operates in a stable way without much user input, which is why some people in my personal IT orbit choose to use it. Add all the security failures that 10.13 has been party to and maybe it's time we just stopped development on OSX for a bit, rolled the codebase back to 10.11 or so, and make the release cycle longer to account for thorough testing first.

    1. Ken Moorhouse Silver badge

      Re: one of my machines has entered a loop of bricking and unbricking itself

      Get it into the unhalfbricking state and then you can perform an autopsy on it whilst pondering who knows where the time goes.

    2. Dan 55 Silver badge

      Re: This is getting really annoying

      Don't you mean roll back to 10.6.8?

      Everything since then has been either a removal of functionality or rainbows and candyfloss which doesn't do much but manages to slow the system down.

  5. devongarde

    My Finder reports 10.13.5.

    1. diodesign (Written by Reg staff) Silver badge

      Re: devongarde

      That's the latest beta. 10.13.4 is the latest "stable" release.


  6. Jay Lenovo

    Apple Update Time

    Shake..Shake.. Roll...

    Doh, the update missed the mark. Take your chances next time.

    1. John Lilburne

      Re: Apple Update Time

      Apple updates are like a box of chocolate covered turds.

      iTunes updates caused me to reinstall windows on 4 occasions. Last autumn they bricked the iPod touch for 4 days. Every other iTunes update screws up the plugin.

      1. Eeep !

        Re: Apple Update Time

        You re-installed Windows 4 times before realising that installing iTunes was the problem???

        Assuming you re-installed Windows (what version?) which must have worked and then installed iTunes which stopped it working.

        1. Ken Moorhouse Silver badge

          Re: You re-installed Windows 4 times before realising...

          In the good old days one could perform an FDISK and Format which pretty well guaranteed vanquishing any [software] demons in there. Nowadays with UEFI etc. I can well understand starting with toe-dipping, moving on to walking on hot coals only if absolutely necessary.

        2. John Lilburne

          Re: Apple Update Time

          XP was the OS that they mostly screwed over. In fact what usually went wrong was the iPod driver. Why they would want to update a working driver with a copy of itself is any one's guss. But after an install iTunes could never access the iPod nano, and the driver reported being screwed. So long as you re-installed iTunes before anything else was reloaded onto a new build one was OK, but 6+ months later an iTunes update would screw the driver again. When borked I had a number of Apple support people try to fix the issue all to no avail. After the last cycle I turned off apple updates. The screw up doesn't happen on win10, but they did manage to fuxor the iPod touch with an iOS update last September, something about the update looking for data on a non-existent/badly configured apple server.

  7. Anonymous Coward
    Anonymous Coward

    32-bit getting killed off for desktop OS?

    Hang on,

    The stupidity of killing off 32-bit apps on iOS, which has caused large number of people to cease updating from 10.3, hasn't been learned.

    And now they're going to repeat this fucking stupid behaviour on their DESKTOP OS?

    They must be Fucking Morons.

    1. Anonymous Coward
      Anonymous Coward

      Re: 32-bit getting killed off for desktop OS?

      No, but they think their customers are.

      They're not entirely wrong.

    2. James O'Shea

      Re: 32-bit getting killed off for desktop OS?

      It's worse than you might think. There's a reason why 32-bit apps are being killed off, and a very simple one: to clear the way for 64-bit ARM hardware. Apple doesn't want the hassle of having to support 32-bit Intel binaries on 64-bit ARM, supporting 64-bit Intel on 64-bit ARM will be enough of a hassle. There _will_ be ARM-powered Apple desktop systems within 18 to 25 months, max. (That's October 2019 to April-May 2020. Mark this down on your calendars.) There'll be some method of translating Intel 64-bit binaries on the fly, the way that 680x0 and PPC binaries were translated in times gone by, but not 32-bit. After a while, support for the translation system will be dropped, just as in the cases of 680x0 and PPC binaries in the past. (I still have an ancient beige Mac G3 and an almost as ancient eMac hanging around to use old 680x0 software, and the eMac and a iMac G5 to use old PPC software. The beige is over 20 years old now, the eMac and the iMac G5 are both over a decade old now. The beige is the last machine I have which still has an original equipment floppy drive which still works.)

      Don't mention 'virtual machines', any VM will have to emulate Intel hardware, which is going to be interesting to do and even more interesting to defend in court.

      There is a truly amazing amount of 32-bit code out there, in old apps, in libraries for old and new apps (Adobe: I'm looking at _you_) and in drivers for printers and scanners and the like. Lots of stuff is going to drop dead with the arrival of 10.14 or 10.15 or whatever. I wouldn't be surprised if the reason why some (and only some) are having problems is that they're running something at a low level which uses 32-bit code... and the little "I hate 32-bit" dialog isn't been clicked on 'cause it's not being seen, because the code is headless or lives deep inside something else.

  8. anothercynic Silver badge

    Check your USB keyboards too...

    ... My Mac Pro disabled the USB keyboard... no amount of unplugging and plugging made it work again. Plugged it into a Windows box, and it was detected ok, then plugged it into the Mac and hey presto... it worked again.

    God only knows what they've done this time...

    1. I&I

      Re: Check your USB keyboards too...

      Cue (altered) Beach Boys song, directed at Apple: “I may not always love you...”

  9. Anonymous Coward
    Anonymous Coward

    I had trouble with the 10.13.4 update on my MacBook Pro. It installed fine, but shit the bed a few days later after I shut it down and started back up the following day. It tried to re-install the OS and failed. A few times. I could only get passed it by starting in Safe Boot (hold the Shift key down while booting). What I found was that the installer had left some files behind at the root of the internal drive that made it think it was supposed to install the update again. These files could not be removed.

    I restarted in Recovery Mode and mounted the boot partition (mine's encrypted and needs to be authenticated in Disk Utility in order to mount it). I then switched to Terminal and removed the files (They were in a folder whose name I do not recall) with rm -Rf /Folder\ whose\ name\ I\ forgot. I was still unable to boot normally, so I went back to Recovery and re-installed. All is well since.

    Just passing it along in case it helps some else. To be fair, this is the first time in years that I have had trouble with an update. I tend to install them right away, as my clients rely on me to advise them of issues and/or sort those issues out when they have trouble. But there is no substitute for backups and, of course, updates that don't hose your machine.

    1. PhilipN

      Thanks for the heads up

      I shall have to try that. Problem is, after choking on the update- install-re-install more than once my Mac Pro crashes randomly. One time ran fine for more than 24 hours (indexing A LOT of music files for Plex Media Server) but then began choking randomly.**

      **Well each time a report is sent to Uncle Mac (who must be bombarded with 'em) so perhaps it ain't so random but who knows? The log is crammed with any and every possible assistance - short of REAL HELP.

  10. PhilipN

    Latest High Sierra and 2013 Mac Pro

    Crashed more times in one week than all my other Macs in 10 years - in total.

    I had to search for an explanation of nothing on the screen but a floating question mark - "cannot find the boot disk". Crikey - welcome to 1988.

    'Course I could rewind to Sierra. But then the SSD is 100% invisible.

  11. tip pc Silver badge

    #Me too!

    My late 2016 MacBook Pro crapped out at upgrade. Backups where a few days9ld and I assumed I was screwed when I had to do recovery mode, twice, but now all is well, it retained everything and just installed the new os over the old. I’ve had issues waking from sleep since day 1 so 5nat usn5 fixed, I often have to force a restart, it haven’t left st anything, even from docs in mid flight I have t saved. I get annoyed when having to reload the work pc and lose my stuff in spreadsheets and notepad.

  12. Oblamo BinLyen

    Zippo Issues

    2 iMacs, recent, 2 MacBook Pros, combination of i5's and i7's, external Thunderbolt to HDMI on one iMac, USB Keyboards & Wireless mice, various combinations and zero problems.

  13. Joe Gurman

    "Numerous reports," eh?

    The nine Macs I manage all updated to 11.13.4 without issue. Not a large statistical sample, but still.

  14. 45RPM Silver badge

    I’ve upgraded a 2011 Mac Mini, a pimped 2009 Mac Pro (with hacked firmware), a 2011 MacBook Air and a late 2013 Retina MacBook. Guess what? I’ve have no problems with any of them.

    It’s not that I don’t believe that this problem exists - but, given my experience with such a wide array of machines, I think that there’s something else at play here. Low available space perhaps (although I’d be surprised if Apple doesn’t check for this before proceeding)? Weird kexts? Even flaky power? It would be interesting to have this further information, but I don’t suppose that we’ll ever get it.

  15. clanger9

    There is an issue with obsolete, unsigned .kexts

    It can manifest itself in crashing, inability to complete install, inability to reboot etc.

    High Sierra is supposed to mark existing .kexts as "safe" on install as part of the new-fangled (and annoying) SKEL system. Unfortunately, that process seems to crap out on some machines, leaving them unbootable (other than via System Recovery).

    Try system_profiler SPExtensionsDataType > ~/Desktop/kextList.txt

    If that process crashes & dies, you definitely have a duff .kext

    Look in the output from that command to find any unsigned .kexts

    They live in /Library/Extensions - remove anything old/suspicious here and try the upgrade again.

    1. RPF

      Re: There is an issue with obsolete, unsigned .kexts

      Interesting. My 2011 iMac became un-bootable (re-install needed via System Recovery) after I changed the Firewall PF settings using Murus (and re-booted to make effective).

      Never seen this before in almost 20 years of using Apple desktops/laptops daily.

      1. TVU

        Re: There is an issue with obsolete, unsigned .kexts

        "Interesting. My 2011 iMac became un-bootable (re-install needed via System Recovery) after I changed the Firewall PF settings using Murus (and re-booted to make effective)"

        Regrettably, Apple seems to be concentrating primarily on iPhones and iOS at the expense of both Macs and macOS and there's no shortage of complaints on Mac forums about how recent releases and updates of macOS have lacked quality control in the past couple of years.

  16. silks

    I'm alright Jack!

    Working fine on my late 2013 Mac Pro :)

  17. Inspector71
    Thumb Up

    I'll just stick to System 7

    1. Cirdan

      System 7...

      ...and the endless Extension conflict reboot dance.

      Good times, good times.


      (LinuxMint, baby, MATE)

      1. Inspector71

        Re: System 7...

        Yes I remember too, Extension Manager was our friend.

  18. Muscleguy

    It isn't just Apple. I naively updated to Google Earth Pro, except it ran like jerky custard and was pretty much unusable. Probably because this mid 2010 Macbook pro is one of those which has to use gfxCardstatus to keep it always on the internal graphics and not the dedicated graphics card or risk a kernel panic.

    So, I tried to use Time Machine to roll things back but no dice. I had to dig about the website to find an install disk for the old version. Even then I would go to use it and find that despite telling it I did not wish to update to Pro there would be Pro sitting there instead. After several iterations I went into the Library and found squatting there like a toad a Pro update widget. It is now totally deleted and all is retro stable.

    Apple keep saying I should update to High Sierra but it isn't that long since I bit the bullet and updated to Sierra so I'm in no hurry for another one. The system updates keep coming nevertheless. I'm not abandoned, yet.

  19. Hans 1

    Going to "Special Update Install Mode"

    I knew this was going to happen at some point, whenever you start being f'd up and require a special mode to install updates you know the devs have forgotten they are developing software for a UNIX system, so sooner or later, shit will hit the fan.

    Anytime a hardware manufacturer decides to solder RAM and SSD's, you know the hardware team are beyond salvation.

    What is left at Apple ? I dunno ...

    PS: I have ran Apple software from OS 8.5 (8.* and 9.* sucked, but not quite as much as Windows 9x) to 10.9 (including 10.0 Beta). I had fond memories of 10.2 with Omniweb, so upvoted commentard above. When fink and homebrew were not around, you would download Xcode and hunt down the UNIX software you wanted, shit, back then, we would download the Xfree86 sources and compile them to run UNIX gui apps on our macs ... how times have gone by.

    1. WallMeerkat

      Re: Going to "Special Update Install Mode"

      Used to be a PPC Mac was an incredible machine for running OSS.

  20. Triumphantape

    Time Machine

    If they used Time Machine to back up, it's a minor affair to restore to prior state.

  21. jonnycando

    I'm on 10.13.5 beta 2 and it's running OK for me. Rendering video takes an age...but it is a several year old mini mac.....and overall I can't complain.

  22. elvisimprsntr

    I ran every 10.13.4 beta without issue on my Mid '14 13" rMBP. Currently running latest 10.13.5 beta, also without issue.

  23. Ian Joyner Bronze badge

    Yes, Register gets it wrong

    Like you said, you could be wrong. Again making some big deal about ‘secrecy’ in Apple. I remember with mainframe work when an update came, you’d print out the notes which would be several hundred pages, mainly for developers. Software moves much faster now, but most users have no interest in this stuff. Developers get it from other sources. Apple is secretive with information that other vendors can pick up because Apple has been severly burnt many times. So there is no case here.

    Register then brings up that Apple secretly updated and rolled back the new file system during an update. Actually, this was the most comprehensive test in history. Apple showed a great deal of responsibility to take the care to do this. But Register puts on its usual anti-Apple spin.

    And this story after I read the article about wireless charging that praised Samsung, even though Samsung seemed to have little to do with the story.

    Register needs to get over its chip on the shoulder about Apple.

  24. Oflife

    These issues go back way before current build

    I am glad to discover I am not the only one. Issues I have with my 15” 2017 MacBook Pro i7 512GB SSD:

    1. Frequent app crashes, inc long list of fatal errors.

    2. Sluggish login when connected to USB-C Thunderbolt hub

    3. Trouble driving more than one external monitor. Monitors flicker on and off and on for ages before going to sleep or finally coming on.

    4. Unreliable charging through USB hub with power thru port

    5. Duet doesn’t work. I have an iPad Pro 10.5

    A lot of the DisplayPort and sleep/wake issues I had with my Surface Pro 4 and previous MacBooks so I concluded after reading on Surface Pro 4 and Apple forums that most of the blame lies with Intel. There is a specific combination of their hardware that leads to these issues and neither Intel Microsoft or Apple appear to be dealing with them.

  25. PhilipN

    One basic problem found - maybe

    Cautiously confident that at least one of the issues is solved - up to a point.

    Mac Pro 2013.

    Seems High Sierra 13.4 does not know how to go to sleep. To whit:

    Re-installed. Immediately began a Time Machine backup and nothing else. Next time I looked the bastard had crashed.

    Happened a second time.

    Changed Energy Saver settings to keep the display awake longer and NOT to allow disks to sleep when display sleeps.

    So far so good. First backup completed. Bloody miracle!

    This did NOT solve the ridiculous install/update issues which again one time ended with a floating frigging question mark on the screen but the OS seems somehow - eventually - to complete the boot/install/update.

    Now on to latest developer preview no. 2 of 13.5. Can't be any worse ..... surely? I mean, this came out relatively quickly so maybe Apple actually reads all the crash reports.

  26. eric.verhulst(Altreonic)

    Contacted Apple, fo which I have to sign up(!).

    Posted this: After installing 10.13.4 my macbook never goes into sleep anymore but reboots instead all the time.

    I hear and read that severla people have now this issue, but no information at all to be found.

    I had similar problems with earlier updates (but not all the time and the issues disappeared).

    I found this information: Apple's magical quality engineering strikes again: You may want to hold off that macOS High Sierra update... • The Regis…

    Please undo whatever you put in that update to avoid this. I use this Macbook for my business!

    When I want to submit I get this:

    You are not allowed to create or update this content.


  27. devjoe

    reboot or shutdown...

    "The initial install appears to be working fine, but when users go to shutdown or reboot an upgraded system, it goes into recovery mode."

    I don't mean to sound smug or anything like that, but I'm just really amazed how reboots and shutdowns are hardwired into peoples habits as something you would willingly do to a computer on a regular basis. I've had a macbook as my sole work computer for a few years now and I don't remember having ever rebooted it outside of what is required by OS upgrades and of course never shut it down. I have maybe pressed the power button twice (in the few years of having this computer) or so to bring it out of hibernation after it had run out of battery on trips, but honestly I have no idea what the power button does if you press it when when the computer is on. I mean, why would I?

    As an emacs user, I'm terribly frustrated when an OS upgrade forces me to restart my editor by forcing a reboot of the OS. The idea that someone would willingly reboot their computer more often than that is hard to grasp.

    So no, I won't be restarting my computer with 10.13.4; it will reboot when the next OS upgrade comes out and forces a reboot. Why else?

  28. Luiz Abdala

    Update woes...

    Why would they be borked upon update, I wonder?

    - Illegal HOME button?

    - Chinese knockoff screens detected?

    Don't be mad, apple fanboi, Microsoft had their own borkiness going this week too with Pro licenses.

    So, let's get out and have a beer.

    Mine's the one with an USB bootable drive with Windows 10 setup on the pocket.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2022