back to article Firmware freakout sends Epson Wi-Fi printers into reboot loop

Epson Wi-Fi-connected printers are repeatedly crashing due to what looks like a combination of a firmware update gone wrong and Google Cloud Print. Reg tipster Terry Bernstein says folks have found that their Epson WF‑3520 printers have been sent into a constant loop of shutting down and restarting over the past day. The …

  1. BongoJoe

    Alternative Solution

    Buy new ink cartridges from our store. Guaranteed not to cause reset loops*.

    *Mostly because the current overpriced cartridges didn't in the first place.

    1. Anonymous Coward
      Anonymous Coward

      Re: Alternative Solution

      That is actually something that Epson appears to be walking away from. Unlike other vendors, Epson has started to produce the EcoTank range that take ink at a more sensible price (think £8 per colour for a 70cc refill, which is actually less money than your average 10cc ink cartridge costs). It's also less of a pain re. ink replacement - especially at A3 format the smallest content cartridges don't even last ONE page.

      Unfortunately my current WF is not yet available in EcoTank (it's an A3+ sized beast), so I'm considering the fit of refillable cartridges but buy original ink - with original ink it ought to print just the same and the costs equal what I would spend in the "alternative ink" market.

      And no, mine's not on WiFi (so no problems, also because I would not trust Google not to have a peek into what I print out), it works *much* faster being hooked up via LAN as the WiFi access point is too far away for a good data rate.

      However, whatever you do, don't let it run dry. Prolonged dry printing destroys the piezos in the printhead and you'll end up with dead "pixels".

      1. Ogi

        Re: Alternative Solution

        I installed a CISS system in my A3 Epson, precisely because as you mentioned, the cartridges don't even last one A3 print, and not only does it interrupt a print (so you have to manually be there) sometimes the replacement ink is a bit of a different mixture, so end up with shade differences, which is obvious on a photo print.

        The CISS has been excellent so far, and no problems with the heads. Just make sure to set the printer to auto turn off after a couple of hours (I set it to 2) as when parked the heads are prevented from drying out.

        I buy ink by the bottle, and it turns out cheaper than having a laser printer, plus can print on all kinds of different materials.

        Looking at this Epson Ecotank, looks like they cottoned on to the CISS concept, and producing their own version. Good on on them, but you might find your printer is already supported by third parties, and you can use Epsons own ink bottles in it if you want.

        As for the article, I tried once to enable Wifi on it, could not be faffed after some struggle, and plugged it into a rasbpi to act as a print server. I can do just fine with ethernet and/or USB on a printer, thanks. I don't need the other features.

      2. Anonymous Coward
        Anonymous Coward

        'Epson Ecotank' still means an 'Epson Land fill extraganza' due to Waste Ink Pad Error out.

        You're sadly mislead by the advertising. All Ecotank Epson printers still have the dreaded Waste Ink Pad Error, which means that the printer has a finite limited number of prints, at which point it errors out. Ecotank just means you have pre-paid for the ink in advance. It's Epson win - win all round.

        The use of the word Ecotank is a misleading advertising term, given finite limited life/page print run (due to Waste Ink Pad Error out).

        'Epson Ecotank' still means an 'Epson Land fill extraganza'.

        Be careful cleaning your Print Heads. Cleaning your Print Head more than 20 times, will get you pretty close to the dreaded 'Waste Ink Error' Printer failure.

        1. Anonymous Coward
          Anonymous Coward

          Re: 'Epson Ecotank' still means an 'Epson Land fill extraganza' due to Waste Ink Pad Error out.

          All Ecotank Epson printers still have the dreaded Waste Ink Pad Error

          Ah, mine doesn't. I know some printers dump the ink on a pad somewhere in the vicinity of the head, but in this printer the waste ink is collected in a little swappable container called the "maintenance box", and I only now start to see it register to have any contents. That said, I did look up the replacement price and that was quite meaty. It starts as $15 when bought in the US, and after transport to the US which must be based on something rare like squeezed seal-oil to arrive at the prices here which are in the region of €25, which directly translates into £25 or more in the UK.

          But at least that problem is dealt with.

      3. Vince

        Re: Alternative Solution

        I'm amazed you've owned an Epson printer long enough to notice any of the other issues. In my experience they suck pretty much from new.

        Like the one we have - 15 months old, has done 100 pages, still on start cartridges - not dried up. Keeps throwing random errors.

        Of the 100 pages, about 30-40 of those have been diagnostic pages with Epson support.

        The result? Ah it's out of warranty, so you will need to pay more than the printer new to repair it, or buy another printer.

        Sure, because about 70 pages from new is totally reasonable.

        Never Buy Epson

        1. Anonymous Coward
          Anonymous Coward

          Re: Alternative Solution

          I'm amazed you've owned an Epson printer long enough to notice any of the other issues. In my experience they suck pretty much from new.

          I have a WF 3520, and am actually quite happy with it. First multifunction I had that can do duplex printing and duplex scanning. And can print from my iPhone.

          I found if I use the right 3rd party cartridges, it's still fairly cheap

          Contrast that with the last HP OfficeJet I had, a multifunction beast that they kept making even after they knew it developed paper feed issues within months.

        2. Anonymous Coward
          Anonymous Coward

          Re: Alternative Solution

          I'm amazed you've owned an Epson printer long enough to notice any of the other issues. In my experience they suck pretty much from new.

          I'm waiting for a bit to see if the one I have (a WF-7610) will come out in an EcoTank version and a rear slot that can handle multiple sheets before I buy a second one - of all the printers I've had in 30+ years I think only the transition from a Star NR10 dot matrix to a whisper quiet Canon BJ 130 bubblejet was more remarkable.

          It even does A3+ edgeless, doublesided, and so does the document scanner although I tend to use that only for A4 printing. It's quite a change to get A3 capability, especially for maps and layouts it's absolutely ace, I'd never want to back to A4 now.

          All that, and I have it running on cheaper ink too, but I'm toying with the idea to fit the next one with a CISS system if there's no EcoTank coming out, but then fill the CISS with the EcoTank inks so I don't have to rebalance colour output - about the only issue with third party inks.

          So no, I'm quite impressed with the one I have because it was also dirt cheap.

    2. phantom69

      Re: Alternative Solution. Uninformed

      If you had any idea of how integrated system communications worked, you would realize this is an ignorant comment.

  2. Anonymous Coward
    Anonymous Coward

    Wonder if it will be possible to cause a Chernobyl-style nuclear meltdown with new firmware upgrades getting pushed out to world+inkjet printer?

    Because I hate inkjet printers with a passion.

  3. Anonymous Coward
    Anonymous Coward


    I decided to disable the Wifi on my Epson a few days ago, and I am still not sure why.

    1. Dan 55 Silver badge

      Re: Spooky

      I went with not enabling any web/email enabled printing or allowing automatic printer firmware updates on my HP. That was when I got it, but I like to think that HP only now releasing updates which close Telnet and FTP ports on their printers means they know sod all about security and I was right.

      1. Lee D Silver badge

        Re: Spooky

        I'd be more worried that someone can send packets to a telnet or FTP port on your local/wireless network, personally, than what the printer actually does when someone FTP's it a PDF.

        If the printer is on its own unencrypted wifi, then - what the hell? Stop that.

        If the printer is on your wireless network or plugged into your network or plugged into your computer? What happens on its telnet port is the least of you concerns compared to "How did someone manage to send controlled telnet/FTP packets around my local network".

        If you're using them in a commercial environment, then you put on IP-based access control (so you have to be in IT ranges to administer the device anyway) and disable all that junk by default. And even then, all your users will be printing via your print server, presumably, so there's no reason you couldn't VLAN off the printers so they can't access them directly anyway.

  4. Anonymous Coward
    Anonymous Coward

    Firmware update on a printer?

    You buy a printer to print, when you buy it, it works and prints as expected. Why would you need a firmware update?

    Granted, all the web printing and internet connected gubbins may need updating but to be fair it's only a fool that allows it to connect to the internet.

    1. Anonymous Coward
      Anonymous Coward

      WiFi connectivity does have some utility.

      The Epson multi-function printers can scan directly to email, and its internal directory can be programmed with email recipients making a scan-to-frequent-recipient a matter of pressing a few buttons.

      However, I would agree with you that you should not allow uncontrolled inbound connectivity, which is why I don't use Epson and Google printing services. Google would love to have a peek at everything you print, and Epson benefits if it gets hacked and some idiot drains your ink by sending sheets of pure colour just to run up your costs.

      1. Vince

        What have your examples got to do with Wi-Fi that a good old Ethernet cable doesn't do just as well?

        1. Anonymous Coward
          Anonymous Coward

          What have your examples got to do with Wi-Fi that a good old Ethernet cable doesn't do just as well?

          My machine uses the house WiFi for connectivity, but the link between the machine and the printer is a LAN cable. All the printer has is a default IP address to receive data from. There is no route, there is no DNS resolution, there's only scan and print and Epson print and Google print are deliberately left unconfigured. Even if I were to give it connectivity it wouldn't be hooked up to inbound external services because I like a double safety net in case I have a daft moment :).

    2. Joe User

      You buy a printer to print, when you buy it, it works and prints as expected. Why would you need a firmware update?

      Because all modern printers contains a processor of some sort, plus built-in programming (more so if they're multi-function devices). Firmware updates are the only way to fix bugs and/or add new features.

  5. Hans Neeson-Bumpsadese Silver badge


    it works and prints as expected. Why would you need a firmware update?

    My default position on most things technological. If it works well enough, then why run the risk of borking it by installing an update that has unintended consequences?

    1. Paul Crawford Silver badge

      Re: update?

      I set my router to block external network access from my printer anyway - it should only EVER need to talk to my PC for print jobs.

      If there is an identified problem that a fix would benefit me then I will apply an update, once its been around for a few days an not broken things...

  6. Anonymous Coward

    I was only running WiFi as a stop gap,

    As a firewall update has blocked it via ethernet - but says it hasnt.

    I can check printer status, but any attempt to print a page fails.

    Finally gave up and stuck it on a direct USB link and it works perfectly, so disabled the Wifi.

    White hair and glasses, that me alright.

  7. Aristotles slow and dimwitted horse

    Google... suspend.

    Never have two words been paired together in such perfect and planet aligning harmony.

  8. RNixon

    Sometimes a modern printer does need a software update.

    If a printer can print, for instance, PDF files from a USB stick or a memory card, it's perfectly reasonable for it to need a software update to support new PDF features. (Adobe is still adding those, right? I ignore PDF as much as possible. It's a terrible format.)

    Or it might need to update the APIs used to access third party cloud printing services. (I think those are silly, but if the printer offers them it'd be best to keep them working.)

  9. CKOne

    WF-7515 has the same problem

    My WF-7515 started playing up, showing the exact same symptoms, and it hasn't had a firmware update for quite some time.

    I only found out as my daughter tried to print a document from her Cloudbook, and the printer started looping. Couldn't even suspend or delete the Cloud Print setting as the printer would reboot before it finished. The only way I could stop it happening was to disable the WiFi on my router, and then reset all the settings of the printer. Before re-enabling the WiFi on my router I also had to change the IP address for the printer, as Cloud Print would try to contact it I assume, and the whole game would start again

    For now I've removed the ability for my daughter to use Cloud print, disabled the WiFi on the printer, and set the IP address for it on Ethernet to a number I'm not likely to need. This means we can still use Airprint, which interestingly "Just Works"

  10. Duffaboy

    Epson QA Department

    Non-existent ?

    1. jake Silver badge

      Re: Epson QA Department

      It's a DevOps thing. If you don;t understand, you're so 1990s.

  11. GaryJ

    Its happening on lots of Epson printers.

    I have an XP-750 that has suddenly developed this problem too. I haven't updated the firmware since purchasing it, so after doing a bit of online research, found out if you disable google print services, it works fine. It doesn't matter if you use RJ45 or Wifi, problem exists.

    Have updated my firmware today and still the same problem, so have disabled google print services until either company fixes this bug.

    1. Dan 55 Silver badge

      Re: Its happening on lots of Epson printers.

      Google's confirmed they've decided to unilaterally change the Cloud Print API. Obviously they had left it alone too long.

      Now Epson should deal more gracefully with the change but the end result is the same - no printing.

  12. Gis Bun

    Epson's reply will be: "This is a feature. It is done so by design."

    1. Anonymous Coward
      Anonymous Coward

      I think you are confusing them with Apple.

      Epson would never say anything so smart/smarmy (take your pick)

  13. Joe User


    Internet of Malfunctioning Things

  14. John 104

    Screw You Epson

    Sorry for you users out there that may have this trouble. Time to grow up and buy a laser printer and be done with this whole consumable printer scam.

    I had a brilliant Epson color print/scan/copy printer years ago. Printed amazing photos. It really did. Then the starter ink got low. OK, I thought to myself, I'll just buy the regular cartridges and shouldn't have this issue too much. $120 later, I had a full set of color and black. 2 months later, the colors were dry. OK, I thought, I can still print documents, right? Wrong. No printing if any cartridge is "dry". As an added bonus, EVERYTHING on the printer stopped working. Need to scan? Oh, well, until you buy ink, that feature is disabled. I was so pissed. I ended up buying a color HP laser printer. Cost a little bit more, but the price per page is vastly lower. No, it doesn't print color as well, but who cares?

  15. Greg C
    Thumb Down

    I have a few of these with the problem.

    No recent firmware updates were installed.

    Disabling Cloud Print on the device helps (device will start up at least) but IME the printer still reboots after a few minutes.

    I found that removing the device from within Google Cloud Print fixes it for us.

    Of course, we're using some of these as printers for Amazon Workspaces (Google Cloud had been more reliable that Teradici redirection)

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Other stories you might like