Screen flickering/Explorer crashing on Windows 10? (fix)

This topic was created by David 132 .


This topic is closed for new posts.
  1. David 132 Silver badge

    Screen flickering/Explorer crashing on Windows 10? (fix)

    I've just run into an odd problem on Windows 10 here at work, and I thought I'd share my experience - and fix - here in case it helps anyone else.

    I installed Windows 10 AU on a Surface Book. Now, those of you who've read my comments elsewhere on the Reg will know that I'm not the world's biggest fan of Windows 10, but this was to replace my old & clunky Thinkpad, and I figured - what the hell, it's mandated by my employer anyway, I might as well go with the flow.

    Anyway. Installed the OS and all apps, everything working fine. Rebooted, and that's when the problem "surface"d (heheh)

    Symptoms: After logging in to the desktop, the whole screen kept flashing on and off. Closer examination revealed that Explorer was crashing & restarting over and over again (the Ctrl-Alt-Del screen was OK). Safe mode was similarly affected. Vast numbers of system errors in the log, generally of the form DCOM got error 1084 attempting to start the service XXX with arguments "Unavailable" or Faulting Application name explorer.exe / faulting module name KERNELBASE.dll. Logging in with a different user made no difference, implying that it was something common to all profiles, and machine- not user-specific.

    Googling for the symptoms didn't really help; as usual, plenty of people with similar problems but never quite the same (e.g. it turned out to be Windows 7 with a bad HDD, or a bad AMD display driver - neither was applicable here).

    I was on the verge of a complete reinstall/rebuild.

    Fix: I managed to bring up RegEdit via Ctrl-Alt-Del -> Task Manager -> Run - not easy, because the crashing/restarting Explorer.exe kept stealing window focus from me every second or so - and navigated to HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ShellIconOverlayIdentifiers.

    There was an icon overlay entry for ERM-something-or-other, presumably added by the Office 2013 ERM module.

    As soon as I removed that key, the problem stopped. Explorer ceased to crash, and all was bluebirds and unicorns.

    So - there you go. Cool story, bro, and all that, but perhaps my discovery might help someone in a similar situation...?

  2. jordandevin

    Screen flickering/Explorer crashing on Windows 10? (fix)

    We've looked at many of the problems that you might experience after upgrading to Windows 10 -- from issues with audio to bothersome browsers. Some users are having problems with the explorer.exe process crashing and an annoying screen flicker. Three particular applications -- Norton Antivirus, iCloud, or IDT Audio -- have been cited as culprits, and Microsoft and Symantec have solutions.

    There's no need to go as far as uninstalling Windows 10, but Microsoft does suggest that you restart your computer in Safe Mode and uninstall any of the aforementioned programs. Of course, Symantec would much rather than you continued to use Norton Antivirus, so the company has its own fix for the problem.

    Restart Windows in Safe Mode.

    Run Symantec's special fixing tool as an Administrator.

    Restart Windows as normal.

    Use the dedicated Norton Remove and Reinstall tool to uninstall the AV software and then reinstall it.

    1. David 132 Silver badge

      Re: Screen flickering/Explorer crashing on Windows 10? (fix)

      Good points, but as I said - Safe Mode was also affected. Very difficult to run anything when Explorer keeps crashing & restarting (and stealing focus away from whatever you're trying to do) once every second.

      I have now encountered a whole litany of problems with this machine, and might post more details on here when I have time. Basic stuff, like: randomly not going to sleep when closed / not waking up; CPU pegging at 100% usage for no reason; discrete GPU flat out refusing to work at all...

      Let's just say that this combination (Surface Book plus Windows 10 AU) is the buggiest, most alpha-quality system I've used in many years. Considering that both hardware & software are from the same vendor, was it foolish of me to expect it to work well?

    2. jake Silver badge

      Re: Screen flickering/Explorer crashing on Windows 10? (fix)

      "We've looked"

      Who is "we", Kemosabe?

      1. Anonymous Coward
        Thumb Up

        Re: Screen flickering/Explorer crashing on Windows 10? (fix)

        Who is "we", Kemosabe?

        Since "we" has so unequivocally identified that problem as being caused by [insert three arbitrary 3rd party app names here], despite Dave clearly stating the cause was an MS Office file / reg entry, then ignoring the rest of his post for good measure, I'd chance a fiver on the mysterious "we" being M$PR


        1. jake Silver badge

          @AC (was: Re: Screen flickering/Explorer crashing on Windows 10? (fix))

          So, AC, what you are saying is that "jordandevin" is another name for M$PR? If so, it would be nice if it IDed itself properly. (Me, I think "jordandevin" doesn't understand the concept of properly attributing cut & paste ... )

  3. David 132 Silver badge

    Thank you all for your responses.

    I didn't create this topic in expectation of any particular results; rather, I thought I'd throw my experiences out there in hope that they might be of interest or help to others (if only as a salutary warning :))

    Here's the full litany of issues I have with this. Any suggestions would be welcomed. I should emphasize that I have installed all the latest drivers - the firmware/driver pack dated 8/4 from Microsoft's own site, and even, in desperation, the individual device drivers from the vendors (Intel Chipset INF, NVidia graphics drivers, etc).

    - Sleep is now completely unavailable. powercfg -a reports that S1/2/3 states are not available because "The system firmware does not support this standby state". I have had to resort to switching the machine off at the end of every day. How 1996. Perhaps there's an ISA IRQ jumper I haven't set correctly?

    - The Nvidia dGPU in the keyboard base resolutely refuses to work. Device Manager reports "Windows has stopped this device because it has reported problems (Code 43).". This might be causing the Standby problem above. Vague allusions on the web to early Surface Books (like this one) having defective hardware and being replaced under warranty by Microsoft, but I can find no concrete evidence of such a process.

    - 50% of the time, when the machine boots up, the Wifi connection associates with our corporate WLAN but refuses to get an IP address. I have to switch to a different SSID to get a real (non-169.254) address. Ipconfig /renew, dis/re-enabling the adapter - nothing else works.

    - Mouse pointer DPI scaling is erratic. My primary screen is set to 200% DPI scaling - the default - which makes the mouse pointer teeeeeny tiny. I've set the cursor scheme to "Windows Black (Large)" to make it a little more visible; every so often, however, the pointer will reset back to teenytiny mode. I've hacked a workaround for this - wrote a little AutoIt script that runs at user logon or whenever required, and opens the Mouse Pointer properties, changes the scheme to something else and then immediately back to the desired one. Ugly, but works. Ish.

    - CPU keeps pegging at 25-90%. Most of the time the culprit is the "System" task (i.e, ntoskrnl.exe). A reboot is required to fix it.

    - Random display corruption (dialog boxes or menus appear as totally black).

    Overall, I'd describe this system as "limping" - Cruft Force 6, for those that remember the Dr Dobb's Cruft scale.

    I pine for my old Thinkpad.

    1. Anonymous Coward
      Anonymous Coward

      Re: Thank you all for your responses.

      And it was definitely fine before you "upgraded" (as MS phrased it)?

      Hasn't been knocked, dropped or otherwise mechanically abused in the meantime?

      What was it running before? 8?

      And you're quite certain you haven't (perhaps inadvertently) installed Norton AV, iCloud or the other one? ;)

      1. David 132 Silver badge

        Re: Thank you all for your responses.

        It was originally running Windows 10 (being a Microsoft Surface Book, as it is), before I updated it to Windows 10 AU.

        Nope, not dropped or abused in any way (other than verbally, on an hourly basis).

        I take great exception to the suggestion that I might have installed Norton AV. How dare you. I have standards. Sir, we shall meet on the field of honour!

        1. Anonymous Coward
          Anonymous Coward

          Re: Thank you all for your responses.

          Do most humbly apologise! It was the MS rep wot started it! ...and you did admit to installing WX... so who knows what you'll run?!

          If it ain't been mechanically/thermally mangled, my initial inkling would be an ailing SSD or the installer buggering up the unmentionable clusterfsck MS & chum replaced BIOS with. I think I'd be inclined to check FS integrity and, if the drive's OK, nuke & clean install... Despite PR's assurances that it can't be MS at fault.

          Keep us posted. Curious to know how it turns out.

          1. David 132 Silver badge

            Re: Thank you all for your responses.

            Currently resetting it back to "clean" using the Windows 10 built-in tools; I'd have vastly preferred to back it up fully and reinstall the OS from scratch, but I couldn't get the bloody thing to boot from USB. Tried disabling Secure Boot, checking the UEFI boot order... even mystical combinations of pressing the volume down button while powering on, which Random Internet Commentators assured me would work. Nope.

            If the dGPU still doesn't work after this, I'll probably chuck the thing in the bin, or give it to a starving intern. Life's too short to waste my time working around other peoples' incompetence.

            Did I mention that before I kicked off the reset, it suddenly decided to nag me about setting up Windows Hello every single time I booted up? For no apparent reason, Hello having been disabled by policy on my domain network?


            1. Anonymous Coward
              Anonymous Coward

              Re: Thank you all for your responses.

              Any joy?

              1. David 132 Silver badge

                Re: Thank you all for your responses.

                Ok, back again with update. It's been a busy few days on the domestic front so my travails with the Surface have had to wait.

                So, I reset it - interestingly, although it shipped with Windows 10 b1511, the "full wipe/reset" option restored it to Windows 10 AU/1607.

                This "clean" installation seemed to have fewer problems - the NVidia dGPU now works, for one - and sleep/standby work too, probably related.

                I've converted it to a corporate build, but in the most minimal way possible - joined it to a domain and installed Office 2013. Leery of possible problems, I've so far resisted my IT department's attempts to push McAfee antivirus/firewall onto it!

                Things aren't entirely problem-free though;

                - the CPU still randomly pegs at about 25%,

                - Every so often after waking, the Wifi card will still silently fail - as in, it claims to be connected, gets an IP address (albeit slowly), but then can't communicate anywhere. Even pinging the local router doesn't work. I have to reboot to regain connectivity.

                - The mouse pointer frequently forgets that it's supposed to be 200% DPI scaled along with everything else, and shrinks back to teeeeeeeny mode. Sometimes it's only one pointer that does it - so, for example, as I use the web browser, I get the normal size "arrow" but then hovering over links gives a tiny little "hand" (yes, I know sites can sometimes provide custom cursors. Not the problem here - I block all that.)

                - Windows Hello isn't available; all the options are grayed out, with a note that "some settings are managed by your organization". Except, it's not my IT domain policy to blame; a colleague has a Surface Book, still running b1511, and Hello works fine for him. I can, however, use Picture Password a.k.a. happy-finger-painting-time... which seems less secure, somehow.

                - I got a pop-up notification yesterday that "_____ has caused problems with the file association for ___files. The association has been reset to Windows Video". Unfortunately the notification vanished within half a second or so! I have no idea which program, or indeed which filetype, was the problem. But what the hell is Windows doing, deciding for itself to reset my file associations?? This irks me - even if I want to associate .swp swapfiles with Notepad, or .CPL files with Firefox, or something equally daft, that should be my prerogative. Grrrrrr.

                - Every so often, Firefox will hang completely, with a message popping up that a script has caused the page to become unresponsive. Telling it to abort the script doesn't change anything; I just get re-prompted. Killing Firefox.exe and restarting is the only cure. I'm more inclined to blame Firefox for this one, even though it always seems to work on my Windows 7 / OSX PCs - let's face it, the Firefox team have put all their work recently into crap like Pocket and Loop and Hello that no-one cares about, rather than memory management or speed.

                Overall - probably about 80% functional.

                I feel better now for having vented some wrath, even if no-one else reads this or cares :)

                1. David 132 Silver badge

                  Re: Thank you all for your responses.

                  (addendum, because re-reading my last post after the editing window expired, I realized it could be misinterpreted)

                  I'd installed b1607 Anniversary Update, as pretty much the first thing I did on the unit. So the fact that the full reset/wipe option reverted it to AU was only, I guess, "interesting" in the sense that AU must have updated the Recovery partition - i.e, Reset/Wipe isn't a "reset to factory condition", rather a "reset to the last Windows 10 version you installed". It seems I have a low threshold for what I consider "interesting"!

                  My original post implied that AU had somehow appeared out of nowhere after the reset. Not so :)

  4. Klein1969

    Hi Everyone,

    I am looking for a 8K-SDI video test signal generator that outputs SDI and HDMI. It should have all the typical 'old' standard multi color bars, cross hatch SMPTE 259M,SMPTE 292M/SMPTE 424/425M and timer etc.

    I have QuestTel 3G-SDI Pattern Generator that can handle HDTV NTSC or PAL and 16:9 formats to 720p and 1080p.

    While I have been able to find a myriad of stand alone units, which is fine I am looking for recommendations, or stay away from's.

    I also would be interested in a USB option if available for true portability (something I can throw in my laptop case).

    Any help would be appreciated!

    Thanks all.


  5. waltercarroll

    There's no need to go as far as uninstalling Windows 10, but Microsoft does suggest that you restart your computer in Safe Mode and uninstall any of the aforementioned programs. Of course, Symantec would much rather than you continued to use Norton Antivirus, so the company has its own fix for the problem.

    1- Restart Windows in Safe Mode.

    2- Run Symantec's special fixing tool as an Administrator.

    3- Restart Windows as normal.

    4- Use the dedicated Norton Remove and Reinstall tool to uninstall the AV software and then reinstall it.

    1. win121

      Here is how to fix Windows 10 File explorer Crashing Problem

      Search Display settings in Start menu search box.

      Now, Click on Display settings.

      Now, Change the size of text, apps, and other items to 150% or 200% or 100%. But do not let it remain at 175%.


This topic is closed for new posts.

Biting the hand that feeds IT © 1998–2021