1. Conundrum1885

    Machine self awareness


    This actually mirrors my observations of strange anomalies noticed by myself and other researchers suggesting that some BIOS chips have a bug that causes some cells to change

    their state in a way that causes the emergence of a primitive minimally self aware system.

    I've theorized that badBIOS, AOA150 BSoD, and a lot of other bugs such as some machines refusing to install windows 10 as their attempt to prevent destruction, aka self protection.

    Just had a machine refuse to boot up yet the drive seems to partially work in a caddy, this machine previously flagged a drive as "Failed: disk read error" yet the same drive when wiped worked fine in an older non DDR3 machine.

    All the hardware worked in other machines but notably when I tried upgrading the RAM on this one it would not work with 4GB or 1GB, yet 2GB 8500 or 10600 worked fine.

    It tried and failed to install itself on my Acer 5220 but on here the symptoms are intermittent failure of the USB ports (used external card) and I also had to clock the DDR2 down to 333MHz to allow Winhex to run without crashing.

  2. Conundrum1885

    Why the downvotes?

    Just saying, these are all genuine observations and I've actually documented this on 5 other machines with similar faults. In fact, changing out RAM on systems if they show even the slightest sign of

    instability is a wise investment and Crucial/OCZ sticks aren't much more expensive.

    It suggests that Rowhammer is actually a real problem "in the wild" and laptop RAM is particularly prone to this sort of glitchiness.

    Interesting note, both 5220 and x520 have the exact same CPU (Core Duo T7300) so perhaps this is something worth investigating?

    I tried as an experiment putting the old Celeron 1.18 Ghz CPU back in and it booted up and ran fine

    but the USBs still didn't work.

    1. jake Silver badge

      Re: Why the downvotes?

      Because that's not "machine intelligence", rather it's human stupidity. Not yours, mind, but that of the so-called "engineers" who can't, won't, or are not allowed to design hardware and associated drivers to a so-called "Industry Standard".

      As a side-note, this 14ish-year-old HP laptop (zv5105) has charged USB devices quite nicely since I bought it when running Linux (slackware-current the entire time). When running Redmond software (all varieties I have tested), not so much.

    2. Solmyr ibn Wali Barad

      Re: Why the downvotes?

      Probably because you got bitten by the old adage - never attribute to malice what can be adequately explained by incompetence / sloppiness / pennypinching. While it may be hard to believe the staggering amount of ersatz out in the wild - never fear, there's even more.

      Have some upvotes for your commendable efforts. And keep digging.

    3. Solmyr ibn Wali Barad

      Re: T7300

      Take a look at CPU errata sheet. Maybe some of it rings a bell.


      GS45 & other Montevina chipsets


      965 series chipsets (Santa Rosa)


  3. This post has been deleted by its author

    1. Conundrum1885

      Thanks for the feedback folks.

      I did notice that on some machines the SPD data is incorrectly read as you can write gibberish to most of that chip and it will still work fine as long as the default speed bits are set right and the checksum is OK.

      Currently going through the microcode to see if there is something which has been overlooked, unlikely on a 5+ year old CPU but its possible.

      Its also worth mentioning that perhaps overheating has damaged some critical pathway enough to cause instability but not totally destroy the chip (hard to do thanks to thermal protection)

  4. Conundrum1885

    Re. Interesting glitch

    Have homed in on a very old instruction which is still used namely one of the MMX extensions.

    I am now suspecting that this is actually a real bug in the chip and not some random OS fail, the inability of Windows 10 to install on either machine are very suspicious.

    Perhaps Microsoft can contact me for more information?

    I suspect that this could also be the cause of some older Atom netbooks notably the HP 110-3000

    not being compatible with anything other than Windows 7 Starter and also the graphics driver issues.

    For anyone not familiar with this fail upon upgrading to 10 it won't display anything at more than 800*600 resulting in half a screen or worse no picture at all despite 7HB working just fine.

    Doing a fresh install of 10 and installing the graphics driver last in 7 mode partially works..

    1. This post has been deleted by its author

    2. Solmyr ibn Wali Barad

      Re: Re. Interesting glitch

      Seconded. How's the instruction named?

  5. Conundrum1885

    Re: Re. Interesting glitch

    Just to add another layer of complexity, it does not seem to happen unless the power is already low.

    I just observed the machine switching out of standby, hard drive lights blinked a few times but nothing on the screen (not even a "shutting down") then it turned off.

    Plugged clover leaf power cable back in and orange light came on, yet checked and battery was over 50%.

    Should also mention that we had severe storms today with nearby buildings being damaged, in fact the radio station took a near direct hit.

    I'm now suspecting that this could *possibly* be some sort of induced surge as SWMBO has just upgraded to 4G phone and this was on a table next to the laptop when it went Strange Loop.

    Re. instruction, it looks like under certain conditions random data ends up in the register and causes a glitch on recovery from standby or as mentioned when the battery is low.

    this also explains why it seems to run fine most of the time, the corruption obviously only occurs under very specific conditions and usually self rectifies (Win7 Home Premium)

    Doing write-up now as also observed a very similar fault on HP 110-3000

    1. This post has been deleted by its author

    2. Solmyr ibn Wali Barad

      Re: Re. Interesting glitch

      Battery level & input fluctuations usually do not matter. Motherboard DC-DC converters will keep internal voltages pretty stable, and cut power off if any boundaries are breached. Unless somebody has screwed up in DC-DC converter design.

      More likely causes:

      - EMI interferences during power surges

      - power saving mechanisms may try to lower RAM refresh rate when battery level gets low

  6. Conundrum1885

    Interesting results


    Power saving is worth looking into, there's an option in the BIOS to turn it on and off.

    Also I can try the original memory to see if this makes any difference, have another temperamental

    stick taken from another laptop with nearly identical (ie BSOD) problems.

    It blue screens within 10 minutes of the first boot so something is obviously screwy yet when the RAM is tested (again PC8500s) nothing shows up.

    I changed it for a known good stick and so far no crashes yet.

    The replacements were Hyundai 10600s 2GB

    1. This post has been deleted by its author

  7. Conundrum1885

    RE. Re. Interesting results

    Swapped out the T7300 CPU, seems to have the same problem so it could be something in the BIOS or a chipset issue that interacts with the buggy microcode on the CPU itself with V1.6 BIOS.

    I've also found yet *another* problem, the LCD on this laptop won't work on a nearly identical machine despite the panels being similar but differing by version number; alternate screen works fine though. symptoms: no backlight or any trace of a picture even with alternate backlight.

    In doing some related work on a Sony Vaio 61611M I also found that sometimes the panel ID chip (EDID) goes bad resulting in no screen; have learned that this can be triggered by a windows 10 update which with certain combinations of Nvidia graphics chip driver and screen nukes a key bit in the EDID resulting in no picture on about the third or fourth reboot (just long enough to conclude everything works)

    Needless to say this has led to me blocking all 10 updates on all my machines!!

    Swapping the chip has fixed the issue on the 15.6W panel so this is a worthwhile discovery.

    1. This post has been deleted by its author

  8. Conundrum1885

    Re: RE. Re.RE. Interesting results

    No combination of hardware and software normally results in a bricked system, excluding the occasional flawed BIOS update on motherboards and/or graphics cards.

    Its actually pretty rare these days, the only other time this happened was when I attempted to flash a BIOS with a version up, using the in BIOS updater.

    This unfortunately bricked the system because the interaction between the AHCI and the flash tool resulted in the drive dropping out mid-update which would not have occurred if I'd used a pendrive instead.

    Cue a 3 week wait for new chip and hand soldering a 44 pin TSOP which fixed it.

  9. Conundrum1885


    Extensa 5220 is dead!

    It was displaying the "system configuration data error press F1 to continue" but when I tried to reset the BIOS the screen went very bright in vertical blue bars and it went off, never to recover.

    Any ideas?

    I've taken the board out with a view to analyze the dead BIOS chip but need another broken Extensa to compare it with or a hex file (fd).

    Inteiguingly two pendrives broke within a week of each other plugged into the PCMCIA USB adaptor with different faults of write protect (64GB) and dead (16GB) both have a Phison controller.


    The dead drive flashes its added-by-me-after-breakage LED in a strange pattern but does not show up even as an unrecognized device.

    I am wondering exactly what the heck happened here because these chips are supposed to be write protected at the factory unless somehow they got missed?

  10. Conundrum1885


    Had to change out another RAM stick. Laptop now replaced (Core i3) but good chips transplanted from my Vaio as they are fine and pre-matched.

    Dare I try the old 1TB HDD from the 520 or would it be better to nuke it from orbit?

    Drive diagnostics on ~8m old Toshiba say good, no obvious anomalies.

    Darn strange, never seen anything like this. The kicker was that the DVD drive suddenly stopped responding and upon reboot (eventually) it simply

    didn't show up at all. Took apart and reseated literally every single connector and moved the connector 1mm closer to the drive and as yet it seems fine.

  11. Conundrum1885

    Also relevant to this discussion


    Essentially this provides theoretical backing for many of my observations.

    Now what would happen if I generated a "Cemi Field" analog using summed data from all the memory and CPU

    activity corresponding to what might happen in a mammalian brain?

    A simple field coil over each of the memory chips would likely work, and adjusting the frequency to a harmonic

    of the refresh rate should be adequate.

  12. Conundrum1885


    Now I've finally established that the root cause may have been a failing motherboard, battery AND USB PCB.

    One of the inputs isn't working on USB PCB B on motherboard A but does on motherboard B with the BIOS chip from motherboard A.

    Motherboard B + USB PCB B went back in the machine and after another HDD clone to a fresh but older HDD all seems well.

    It still won't run with more than 4GB RAM but no ideas why, perhaps some chipset issue?

    4+2 or 2+4 randomly fails on recover from Sleep, 2*4 nothing.

    The failing Toshiba x300 drive has one reallocated sector but can't find where it is located.

    It does run hot so perhaps this may explain a few things?

    If the battery was failing then perhaps the controller went Strange Loop and undervolted the drive resulting in

    a low flying write over something important.

    Note: transplanted BIOS as it has my Windows key in it and want to preserve the working system if possible.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon