back to article Apple – it's true: iPad Pro slabs freeze when plugged in to charge

Apple has confirmed its iPad Pro tablets sometimes freeze while recharging. The Cupertino giant has published a support document acknowledging that its new 12.9-inch tablet has a tendency to lock up when plugged in for a battery charge, requiring a hard reboot to revive it. This comes after people have been complaining for …

  1. Anonymous Coward
    Anonymous Coward

    What's the big deal?

    You're charging it wrong...

  2. Mr.Mischief

    Its a feature

    It makes the tablet more secure while you're charging it.

  3. JassMan
    Joke

    Probably the users fault

    In the same way that the SmartWatch will only work with the "special" Apple version of a Qi wireless charger, the users are probably trying (abeit accidentally) to use an ordinary iPad charger in place of the special "Pro" charger.

    1. Matt Bryant Silver badge
      Happy

      Re: JassMan Re: Probably the users fault

      "....an ordinary iPad charger...." Indeed, I was wondering if the problem was just some over-active Apple code of the type that whines if you use a non-Apple (as in "you have not paid the Apple tax") but perfectly operational charges or cord with the other Apple devices. Apple has got so paranoid their devices are now rejecting even their own chargers! Strangely, I have used Blackberry, Nokia, Sony, Samsung and HTC phones for years with chargers from different vendors without any problems at all....

      1. Solmyr ibn Wali Barad

        Re: JassMan Probably the users fault

        "Apple has got so paranoid their devices are now rejecting even their own chargers!"

        Yes it has. Had to troubleshoot an intermittent iPhone 5 charging problem. After upgrading to iOS 8.1.2 it sometimes complained that the original charger is unsupported. Reversed the plug, charges fine. Reversed again, charges fine.

        The cause turned out to be rather simple - a slightly oxidized contact on the data line. Bugger.

  4. Charles Manning

    Hmmm requires a bard reboot to fix it...

    That's not very promising. It sounds like a hw bug rather than a sw bug.

    Sure, there could be some weird interrupt lock up, but from what I read here this sounds more like the charging is causing the hw to get in some screwed up state rather than just a straight software problem.

    That would be a bugger for Apple.... hw recalls are expensive.

    1. Stevie Silver badge

      Re: Hmmm requires a bard reboot to fix it...

      If you don't know any bards I think you can ask a plumber instead.

      But then, try getting one of them to show up when they say they will.

    2. Paul Hovnanian Silver badge

      Re: Hmmm requires a bard reboot to fix it...

      I think that I shall never see;

      A thing a flakey as IT.

    3. Captain DaFt

      Re: Hmmm requires a bard reboot to fix it...

      But where will we ever find a lute player at this hour?

      1. John Brown (no body) Silver badge

        Re: Hmmm requires a bard reboot to fix it...

        Email his agent. He has the power.

  5. Anonymous Coward
    Anonymous Coward

    In a company I once worked for the senior management decided to switch from one firm to another for some software. The previous vendor who we liked had a system that didn't require any specialist hardware and could be controlled using a standard keyboard and mouse. The new system required a special keypad that only they supply as well as another monitor because it was so 'advanced' that everything couldn't be displayed on one screen. Then one day it all went wrong the special keypad on one computer doesn't work, so we swap it for a spare we know works. Only this one now refuses to work as well, but tested on another computer both work fine. We check the USB ports and it isn't them either, machine is operational and we want to avoid having to reboot it as the spare is being fixed. Running out of options we restarted the software and still nothing so we call the vendor and ask why their software is crap sorry that should have read not working with their hardware.

    Vendor takes notes says we'll call you back and eventually does having had to wait for their US offices to open so they can obtain help themselves. They tell us that if it is a hardware fault we're looking at new expensive keypads needing to be bought. 20mins later we are told to open task manager on the computer and read out each item that is running. They tell us that two items are missing and we will need to have these running to get the keypad working again. Turns out that their keypad needed one of those programs running to translate the the output of the device into combinations of keys you could enter yourself on a standard qwerty keyboard. Deeply unimpressed as these keypads weren't cheap and we realised we could just DIY one.

    1. Anonymous Coward
      Anonymous Coward

      A software update had been applied that changed the two offending programmes from starting when the software did to starting when the machine booted up. This was not mentioned anywhere in the support info and really didn't improve relations which were strained in one direction already.

    2. Pascal Monett Silver badge

      A special keypad

      If you're talking about software running on a PC, there is zero reason for a special keypad and there is no software for which a bog-standard, 100+ key keyboard cannot suffice. You could replace the keyboard with only a number pad, but there is no reason to require a keyboard and another input device with keys.

      This reeks of snake oil and it would seem that their autolaunch tasks prove it.

      Personally, I would never accept being told that software running on a PC need any input deevice beyond mouse + keyboard. Not for my needs anyway.

  6. Nanners

    My iPhone 5s charger

    Caught on fire this morning. The wife's blew and sparked a few weeks ago. It's like they are on a timer. Cheap Chinese crap would have burned my house down had I not been watching it. Too bad it's still better than the alternatives... #pleasegetyourishtogether

  7. Anonymous Coward
    Anonymous Coward

    Don't use generic electricity

    Please only ever use Apple iTricity [TM]

    * Not available outside the US.

  8. Anonymous Coward
    Anonymous Coward

    The smell of excrementis in the air

    I find it very unlikely that no one at Apple would have noticed this during the test phase. Not a single tester pligged in his ipad while using it ? This incident leads me to believe that :

    a. Apple does NOT do in-house testing, or

    b. They knew about this, but delaying the product would affect the bottom line and someone found this unacceptable.

    I can't decide which I think is worse, but any chance of me forking over 1000 Euro's for an iphone 6s just discappeared out the window.

  9. Kevin McMurtrie Silver badge

    Can-do

    This will get the usual modern electronics solution: Fix it in software no matter what. Use software even if it means saving the internal state to flash memory when you plug it in and rigging up some other chip to power cycle the board when the main CPU stops. Tell customers to that the device is becoming obsolete and it's time to buy a newer one that works better.

  10. Anonymous Coward
    Anonymous Coward

    iThink

    That only iTwats buy this iShit and drink the iKoolAid.

    1. Anonymous Coward
      Anonymous Coward

      Re: iThink

      should have bought something useful like a Surface 4

  11. Anonymous Coward
    Anonymous Coward

    re It appears to affect only the iPad Pro.

    So why is there page after page of this in Apple discussions on an often identical scenario. Cos Apple said nothing wanting the stuff that actually sells to appear perfect?

    https://discussions.apple.com/thread/7249096?start=60&tstart=0

  12. Stretch

    https://www.youtube.com/watch?v=rX7wtNOkuHo

  13. Anonymous Coward
    Anonymous Coward

    Is this the contraption thats supposed to replace my pc?

  14. PrinceFloppy

    Is this the contraption thats supposed to be able to replace my PC? Good job Tim!

  15. Sleep deprived
    Joke

    No easy solution

    I heard it also freezes if you never plug it.

  16. Sgt_Oddball Silver badge

    call me a cynic

    But when was the last time apple released anything and it 'just worked'? I'm not trying to be so down on Apple but it seems alot of their stuff comes out, it ends up having some technical issue that seems rather slack that they've missed it.

  17. Angry_Man

    Testing

    They just don't test anything, happens all the time.

    Shiny shit but just doesn't work. OS X is flakey as and don't even get me started on OS X Server!

  18. Simon 26

    Well...

    ... that is ONE novel feature that they didn't copy from Samsung's Note Pro. :-)

  19. Bill Fresher

    Turning on Hey Siri appears to fix this issue.

POST COMMENT House rules

Not a member of The Register? Create a new account here.

  • Enter your comment

  • Add an icon

Anonymous cowards cannot choose their icon

Biting the hand that feeds IT © 1998–2021