back to article Sony: PS3 leap year glitch caused network lockout

Old-style PlayStation 3 consoles are now able to reconnect to the PlayStation Network, after a glitch in the machine's internal clock blocked access to the online service. Sony last night confirmed early claims that the clock was to blame. The bug caused the console to treat 2010 as a leap year and so change the date at …


This topic is closed for new posts.
  1. Dabooka Silver badge

    I'm confused..

    If changing the date to the 2nd of March is now possible and will correct the syncing problem with PSN, why wouldn't it work yesterday when people tried to change it to the 1st?

    I'm sure someone can explain the differences to me!

  2. StooMonster

    apocalyPS3 averted

    Loving Sony's PR spin today, being reported by BBC etc., that they have fixed the problem.

    Although they don't appear to have explained their "fix" consisted of them crossing their fingers, closing their eyes, repeating "Please! Please! Please!" all day, and waiting for 1-Mar-10 to pass into history.

    Ta-da ... fixed!

  3. Annihilator Silver badge


    In all my years of learning variably advanced algorithms for leap year detection, I've never seen one come up with 2010 => true. Pretty impressive. Especially as it only affected the fat PS3s, which implies it's a hard solution and not soft?

  4. Jess

    Sony will have a fix within 24 hours?


    They mean normal service will be restored.

  5. Annihilator Silver badge

    Follow up

    Ah, it was a hardware glitch. The ARM SYSCON chip that looks after menial tasks.

  6. Filippo

    firmware patch?

    I don't see the point of issuing a firmware patch specifically to address this bug. Assuming that the bug is something like "every even year is a leap year", the next reoccurrence will be in 2014. The fix can be added to any of the normally scheduled updates. Or, from another point of view, the cows are already out.

  7. Anonymous Coward

    Wot? No ntp client?


  8. LuMan
    Paris Hilton


    Hmm.. I've got one of the fat old PS3s and mine worked fine.. Strange.

    Is it worth Sony sending a patch for a leap year issue that happened in the past?? I'd have thought any new OS updates would be future-proofed.

    Paris, 'cos I can't really think of a suitable icon.

  9. Stone Fox

    batten down the hatches!

    and prepare for an invasion of red-ring-of-death sporting, commentard, my-console-is-better-than-yours microsoft apologists in this space...

    1. Rattus Rattus

      So you thought you'd get a head start

      on the fanboyism?

      Besides, we all know consoles, no matter who makes them, are for the unwashed masses, not the glorious PC-gaming master race!

      Yes, I do watch Zero Punctuation, why do you ask?

  10. Barry Tabrah

    Complex mathematics?

    How is such a mistake possible? I mean, how difficult is it to tell if a number can be divided by 4 or not?

    Mind you, it shows that Sony never thought that their chunky consoles would last this long.

  11. Rich 27
    Thumb Down

    articles wrong

    changing the clock manually to the 1/3/2010 didn't fix it. I tried and tested that theory the minute they claimed it was a date bug.

    Also tried changing it to other dates and all resulted in a load of error messages everytime I tried looking at playstation store.

    Didn't risk any games as some have over 6 months worth of game time on them. Getting my disgaea characters to level 9999 again would have resulted in my and a sledge hammer seeing some action :)

  12. Mike Scott

    No Patch

    Seems unlikely there'll be a software patch, given that the problem will presumably not re-occur until 2030.

  13. Tom 15


    Surely it wasn't the time synchronisation that was the issue but more the fact that 29/02/2010 doesn't exist?

  14. Frostbite


    My PS3 was dead at 11:58pm GMT but was online again a minute past midnight.

    I had to laugh at the news reports this morning at Sony saying they had "fixed" it.

    Yerrrr riiiiiight. - don't take credit for it Sony, nobody is buying you did anything but panic.


  15. Kanhef
    Paris Hilton

    Creatively stupid bug

    I can understand forgetting the rules and writing a function which thinks that 2000 wasn't a leap year, or even that 1900 was. But how did they manage to get confused about 2010? The calculation should always start with "if (year % 4 == 0) ..." [or "if(!(year & 3)) ..." if you want to save a few instructions].

  16. John Goodwin 4

    Working again, Sony - pull your socks up

    My old fat PS3 didn’t work properly all day yesterday, and the only games I could successfully play were Colin McRae ‘DiRT’ and one of my old WipEout 2097 games. All the others failed to start with some trophy/copyright error. I’d tried setting the clock manually beforehand to see if it would ‘fix’ things but it didn’t.

    Switched it on at 12:20 am this morning (minus RJ45 network connection) and without contacting the internet or doing anything else, my PS3 was then back to complete normality.

    2 things.

    1) Sony appear to have let 24 hours pass to let the bug fix itself.

    2) More worrying is that my system wouldn’t let me play more than 90% of my games.

    A poor show Sony, and the lack of updates was inexcusable. I’m currently on the 5th PS3 (initial 60Gb launch model) so you could say I’m more patient and loyal than some ;-)

    Give it a couple of days and there will probably be a new firmware update, applicable to just those old ‘phat’ PS3 owners.

  17. Scott 19


    PS3 owners.

  18. Uk_Gadget

    Wrap it in a.....

    ....towel and turn on. Leave to cook for 15 minutes then cool rapidly. This should reset the clock ok...

  19. JeffyPooh

    It's not that complicated

    Every 4 years is a leap year, except every 100 years isn't, but every 400 years is.

  20. Inachu

    I have a PS3 slim!

    Since the reporting I have been experiencing netwok issues such as long sign in times and when logging out many times it does not really log out but crashes to the main menu OS.

    I'll try again tonight as this happend to me 2 days ago.

  21. SuperTim


    The news people made this sound like the end of the world, rather than a date glitch which was easily fixed. still, good job i didnt use my phat ps3 yesterday. All is fine today.

    phew. Banana skin avoided!

  22. steogede

    How exactly...

    ... do they manage to confuse 2010 for a leap year? All they need to do is check whether it is a multiple of four or not (assuming that the PS3 won't be around in 2100).

    I am amazed that some can get a job programming the OS of the most advanced games console known to man (cue XBox fanbois) - yet be incapable of a simple 'if (year % 4 == 0){...}'

    I think the comparisons with the Y2K bug are offensive to COBOL programmers.

  23. James O'Brien
    Thumb Down

    So no fireware update announced?

    Which if Im not mistaken means we should hear about this in another 4 years again or so, unless the PS4 comes out by then.

    My question is this, how shoddy is QA for the software to let something like this go through?

  24. Daniel Owen

    Firmware to fix?

    Oh yeah they are really going to rush that one, they only have two years to fix it :)

    1. Richard 74

      @Firmware to fix?

      Unless thats two years by Sony's standards of leap year understanding, it's four years, since 2008 came and went without a problem for it.

      And to those wondering why changing the date didn't work. When people opened it and removed the NVRAM battery, and then set the date to 2/3/10 onwards, it worked fine, since there's two dates stored on the system, the manually adjusted one and the onboard one.

  25. Rick Brasche

    sorry couldn't resist

    "Clock Blocker? :P

  26. MarkOne

    Freescale to blame (again)

    Same RTC as the Zune...

    SO it was Freescales fault, not Sony's then..

  27. Jonny Knows Best

    Worst Excuse....Ever!

    Sez it all really :-)

  28. Raspy32


    Assuming that one of the chips had a misunderstanding of date and thought that 01/03/10 was actually 29/02/10 then won't it still be a day behind?

    Of course, it'll work now as it's back to assuming that the date is a day which actually exists, but today for example it may think is the 2nd March (when at time of posting it is the 3rd).

    It may just be me not understanding how it works but logically it would seem that it still sits a day behind the rest of the system.

  29. Jim 15

    "Once the consoles' clocks changed to 1 March" ????

    You need to do more research before making assumptions! Why not talk to actual PS3 users, there's enough of us on here :-)

    My PS3 failed on Monday (actually, both of my PS3s failed) and the bug caused the clock to roll back to just before midnight on 31/12/1999, not 29/02/2010 as you reported. I then manually reset the clock to 01/03/2010 but could not log in to PSN. The next day, Tuesday, I could log into PSN, but the clock now showed a date in 04/2010 before I corrected it, NOT 01/03/2010 as you report. So the problem is probably a leap year miscalculation, but not as you describe it.

  30. MarkOne


    No, the RealtimeClock was trying to set the OS Clock to Feb 29th, which the frontend clock refused to do, because it knew that was a bogus date.

    Some PS3's (most of the 80GB units, and all the slims), the RTC was setting the correct date.

    In a way, the PS3 firmware was TOO smart, it knew the date the RTC was trying to set was bogus and refused to have it. The fix is either to code a workaround in the PS3 firmware so the next time the realtime clock tries to set a bogus date, rather than refusing to accept it, it does something more sensible like patch the date temporarily until the Realtime clock starts trying to set a valid date again.

This topic is closed for new posts.

Biting the hand that feeds IT © 1998–2021