Ye Bug List

This topic was created by Andrew Orlowski .

COMMENTS

This topic is closed for new posts.

Page:

  1. Andrew Orlowski

    Ye Bug List

    Shaun's tried to post this on the Boot's thread: Philosophy is not dead, it just smells funny. I see an "Approve" and "Reject" buttons - not sure why - but Approve doesn't work. Did it trip a spam checker?
    1. TeeCee Gold badge

      That post has just triggered a gripe. Not a bug per se, more a "wouldn't it be better this way?".

      Any chance we could make inline URL references like that lot open in new tab by default[1] with some jiggery pokery[2] behind the scenes?

      I doubt it'll do El Reg's page view counts (as crowed about elsewhere) any good if you keep shoving your readers off permanently to A.N.Other site whenever some commentard's reference piques their interest. Already here you can see that the locals are like a fat kid given 50 quid and let loose in a sweetshop when it comes to the use of URL references and when this hits the main site......

      [1] Yes, there almost certainly is a config option squirreled away in here somewhere to make clicked URLs open in a new tab, but most of the time I don't want to do this. However, I would like El Reg to stay around while I look at things referenced.

      [2] No I don't do this web stuff. Why do you ask?

      1. Sir Runcible Spoon

        @TeeCee

        "you can see that the locals are like a fat kid given 50 quid and let loose in a sweetshop"

        Oy! I resemble that remark!

      2. Anonymous Coward
        Anonymous Coward

        I'll see what we can do about the tab.

        1. Sir Runcible Spoon

          Cake

          Have linkies been disabled in t' main forums then?

          1. BristolBachelor Gold badge

            Sir

            I just had a look at your cake link (on the article). I assume that you didn't actually put a link in it? If shows up as a link, and highlights like one, but has no actual payload.

            Although the cake link here goes to a funny picture :)

            1. Sir Runcible Spoon

              Sir

              I used the same html in the main article (I think) that I posted in here. I'll have another go in preview mode and see what shows up.

              1. Sir Runcible Spoon

                Sir

                Hmm, it worked this time.

                The source for the previous post where the link didn't activate was

                < p > < a >Dangers of Cake < / a >< / p > (without spaces obviously).

                I definitely pasted the link into the original posting. I'm wondering if I misplaced a chevron somewhere and it got thrown out by the parser - but I would have thought it would just have pasted the text in, rather than an empty link.

                1. Anonymous Coward
                  Anonymous Coward

                  Re: Sir

                  You should get an html error message in red - so maybe a missing chevron was not to blame.

                  1. TeeCee Gold badge
                    Thumb Up

                    Yup that's working. I just got a chevron barse-ackwards elsewhere and got the Red Bar of Incompetance thrown at me.

          2. Anonymous Coward
            Anonymous Coward

            Links have not been disabled. Once you have them, you have them everywhere.

            Unless you have found a bug of course.

            Here is something I did earlier ...

            1. TeeCee Gold badge
              Happy

              >Here is something I did earlier ...

              Something in a new tab no less. Marvellous! I can carry on being a lazy git and clicking on links without thinking now......

      3. BristolBachelor Gold badge
        Thumb Up

        I hadn't really thought about this, but what is the chance that the Reg's page impressions are from all the page loads/reloads when people vote? Please, pretty please can the voting be done on the same page? (At work only about 50% page requests get through the firewall sometimes, and even then may take a minute to load, so voting is really expensive for me. Bloomin VPNs and firewalls and low-capacity links :(

        Oh, I don't mind a link opening in the same tab; I normally middle click links anyway to open in a new tab.

        1. Anonymous Coward
          Anonymous Coward

          Re: page load upvote | downvote

          the reload is a small fraction of a per cent! However, we are planning a code release in coming weeks which will purge the site of this annoyance.

          1. Reginald Gerard

            Re: page load upvote | downvote - Ergonomic tip/request

            Hello Drewc, first off, I agree, let the voting work from the comments page, why load a new one? It works well in the New York Times comments. Another thing that has annoyed me with the voting, has been the fact that the "Return to Forum" link is at the bottom of the page. I have the mouse in my hand to locate and click 'Up Vote' / 'Down Vote' so letting go to click on backspace is one action too much. Scrolling down the page to get to the "Return to Forum" is also a pain in the butt, I've already read the entry, that is why I am voting, and I shouldn't have to go to the bottom of the page to return. Please move the RtF to the top of the page.

            Thanks and regards,

            Reg

            1. Anonymous Coward
              Anonymous Coward

              Re: page load upvote | downvote - Ergonomic tip/request

              I have upvoted your comment to remind my self of positioning... Yep, makes sense, but only if we are retaining new-page load for voting - which we are not. See our Forum Wishlist - complete with roadmap.

              1. jake Silver badge

                Re: page load upvote | downvote - Ergonomic tip/request

                I have downvoted your comment to remind yourself of my position ... Nope, makes no sense, because y'all are retaining new-page load for voting - which is senseless. I've reviewed the Forum Wishlist - complete with roadmap - but I still disagree.

                Hint: People likely to vote aren't seeing advertising. Save yourself some bandwidth.

                1. Anonymous Coward
                  Anonymous Coward

                  Re: Re: page load upvote | downvote - Ergonomic tip/request

                  jake we are not retaining new-page load for voting - we just haven't discarded it yet.

                  1. jake Silver badge
                    Pint

                    Re: page load upvote | downvote - Ergonomic tip/request

                    I miss-read yours. I usually know better than to post before my first cup of coffee. Removed "down vote", not that I think you give a rat's patoot about "votes" anymore than I do ;-)

                    ANYway, mea culpa. My apologies, this round's on me.

        2. nichobe
          Pint

          This really irks me. Page voting inline would be a huge plus. It also would stop it asking you to log in after each vote.

  2. Anonymous Coward
    Anonymous Coward

    I see Approve | Reject buttons in article forum pages. Not sure that I should. I hit approve button today - it worked. I hit approve button for a comment to another story - pulled up 404 message.

  3. Anonymous Coward
    Anonymous Coward

    Commentards need upgraded accounts to post html

    In this trial we are doing this manually. I have upgraded Shaun's account

  4. Trevor_Pott Gold badge

    Approve/Reject

    Oh, are we not supposed to play with those? I have been "approving" any comments that didn't look libelous on threads I encounter. Sorry if I am not supposed to touch them!

    1. Anonymous Coward
      Anonymous Coward

      Re: Approve/Reject

      That is just fine, Trevor. But I think this is an unintended consequence of change. Certainly wasn't specced to be for story comments

      1. Trevor_Pott Gold badge

        Interesting tidbit:

        I had to "approve" your comment. Is your user account not set for auto-moderation?

        1. Anonymous Coward
          Anonymous Coward

          It is a bug - or a feature. Comments I make using our CMS are not auto-accepted. Comments I make via the public interface are. It is on my snag list.

  5. BristolBachelor Gold badge

    CR / LF

    Someone else posted something about this somewhere else, but I can't find it right now. Anyway it seems to be a bug, so lives here.

    Typing in a new post (no cut/paste) and pressing Preview leaves a blank line between all lines in the preview, and also changes the text in the edit box the same. (IE8 on XP) I don't know what is does when the text is then Submitted; let's find out without a preview.

    1. Vic

      > a blank line between all lines

      I believe this is down to the way the text is parsed (and possibly even stored).

      Each line of text you write becomes surrounded with <p> and </p> tags. This creates the blank line.

      For a little while after the code was changed, these tags were missing from posts (so it all ended up in one big jumble). Once that bug had been fixed, the jumbled posts were not sorted out. This leads me to suspect that the line-breaks are inserted during initial parsing, and stored like that too.

      But I could be wrong on that :-)

      Vic.

  6. Sir Runcible Spoon

    Sir

    You may need an auto-wrap for stuff that idiots post with no spaces in it </sheepish grin>

    such as

    spamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspamspam

    1. TeeCee Gold badge

      I'll bleat to that one too......

  7. Renato

    Mobile version

    No thread status icons (such as whether the thread is sticky, locked etc) are shown on the mobile version of the user forums.

    And just now I have noticed: it isn't possible to add icons to posts using the mobile interface!

  8. Vic

    That's broken it...

    "Newest" and "oldest" thread ordering now appear to be identical...

    Vic.

    1. Anonymous Coward
      Anonymous Coward

      Fixed

      Thanks for the catch

  9. stuartnz

    Þe bug list

    Just testing to make sure this thread could display a thorn properly. It seemed important given the thread title. :)

  10. Alan Mackenzie
    Boffin

    Missing word in the comments guidelines.

    "We don't the forums to turn nasty and uncivil." is missing the word "want". Please fix it!

    1. Anonymous Coward
      Anonymous Coward

      Re: Missing word in the comments guidelines.

      Done. Thanks for the catch.

  11. Ben Tasker Silver badge

    Thread, Newest, Oldest

    Might just be me, but if I visit a thread that I previously sorted in "Newest" order when it loads the 'Newest' button will be grayed as though it has remembered my preference but the page is still in thread order.

    Means I have to click 'thread', wait for that to load and then whack 'Newest' again. Yeah I know, two extra clicks *grumble grumble*

    I await suggestion that I auto-fornicate and just put up with it :D

  12. Sir Runcible Spoon

    Sir

    Just found a doozer :)

    I looked through the features forum, sorted on new posts.

    Chose a post I wanted to view the previous comments on, so clicked on the # (which took me to the post on it's own).

    I then clicked on the little doohicky dash thing that usually takes me to the very same post but in the main flow of comments and got a loop going..

    this is the url it gave me:

    http://forums.theregister.co.uk/forum/2/2012/01/23/BristolBachelor_New_forum_Wishlist/#c_1305135

  13. TeeCee Gold badge

    Just clicked on....

    ... the "is IT service being destroyed by due process ?" topic by Denarius and got a 500 error....

    Someone's managed to b0rk something publicly at last!

    1. Anonymous Coward
      Anonymous Coward

      Re: Just clicked on....

      Oh bugger, thank's for the catch.

  14. jake Silver badge

    I'm probably missing something ...

    In "http://forums.theregister.co.uk/my/forums/" I have two lists.

    One is the forums I've created. The other is the forums I've commented in or stared.

    Surely the forums I've created should be included in the Venn diagram of the forums I've commented in?

    There is a reason that decent Usenet News software chose a tree format ...

    1. I ain't Spartacus Gold badge

      Re: I'm probably missing something ...

      I noticed that as well. It seemed like an odd design decision.

      The topics you've started are also listed under the topics you've posted in, so you also get the link underneath telling you how many posts have been made since your last one.

      I guess it does make sense though. If you've started a topic, you're more likely to care about it, so you might want to see it at the top.

  15. I ain't Spartacus Gold badge

    New bug discovered in Topic Titles

    I've found a bug with your new Topic titles. Whereas comment titles don't seem to accept html (I've tried), Thread titles don't strip it out the same way.

    So if you go to the Reg Matters forum, you'll see this topic I created. From the forum the title looks like a clickable link, but you can't click on it, and don't get the 'hand' pointer when you hover over it.

    So I appear to have broken it.

    The url is: http://forums.theregister.co.uk/forum/1/2012/02/21/I_aint_Spartacus_a_hrefhttpwwwbbccoukBBCa/

    So it's taken the link tag I put into the title and stripped out the '<'s and '/'s, but still seems to be operating as some kind of botched link.

    1. I ain't Spartacus Gold badge

      Just to add

      In my 'My Forums' page, the new topic title turns up as a black semi-link. It's no blue/red like all the other hyperlinks, and you don't get the pointer turning into a cursor, when you hover over it. Nor does the url appear at the bottom of the screen.

      However when you mouse over it, the colour changes to grey and the underline appears, like a link.

      Clicking on it doesn't work either.

    2. I ain't Spartacus Gold badge

      More to add

      You can also use tags in the Topic titles, but not in the post titles, which I suspect is an error. See my topic here.

      Note that I used: http://www.bbc.co.uk/ without the < a > href tags this time, and they don't seem to have had the same effect. The title is a working hyperlink in the forums, and shows up properly on the 'My Forums' page as well.

      1. I ain't Spartacus Gold badge

        Re: More to add

        Created a new topic with just the title: www.bbc.co.uk

        No problems. It displays as a proper link.

        Also the title of the first post, which should be the same as the topic title in all 3 cases seems to be showing what I typed. It's just that post titles seem to ignore html, whereas topic titles don't.

        1. I ain't Spartacus Gold badge

          Re: Re: More to add

          Just created another test topic. I suspect it's irrelevant, if you're just going to disable html in topic titles, as you do in post titles.

          The topic is here.

          This one has no title at all on the forum front page. All it is was a link to the El Reg front page, where I hadn't filled in the link text element. You get this url for the page:

          http://forums.theregister.co.uk/forum/1/2012/02/22/I_aint_Spartacus_a_hrefhttpwwwtheregistercouka/

          The other interesting behaviour is that it doesn't show up at all on my list of topics started in the 'my forums' page. There's not even a blank line where it could go.

          Also, when TeeCee posted in there, I got a message in the section underneath the topics I've started - in a line, on its own, that said: "1 post since you last posted". There was no link to click on with this, or even space at the start of the line for an invisible one.

          1. TeeCee Gold badge
            WTF?

            Consistancy, we've heard of it.....

            I see that Bristol Bachelor has just created a topic in "Science" called "SPACE the final frontier."

            In the User Sections page, it shows as "Latest Topic" with it's markup exposed in the title. Going into "Science" it shows as a topic with "SPACE" in bold. Going into the topic itself, the FP has the same title (of course) with its markup exposed as seen in the User Sections page.

            Whichever route is eventually taken on the whole "markup in titles" thing, the presentation should at least be consistant......

  16. TeeCee Gold badge

    Here's another one.

    Just found a nasty "feature" while composing that last reply.

    My login just did the timeout thang without my noticing and the post preview stopped doing markup. I reckon that either interpretation of markup in preview should be governed purely by the user email, regardless of login state, or the password prompt needs to move to be required for preview if markup is detected.

    I only figured out what was going on when I hit "Submit" and got the prompt. 'Til then it just seemed broken.

    1. I ain't Spartacus Gold badge

      Re: Here's another one.

      You also can't sort topics by newest/thread, if you're not logged in, as the drop-down box at the top disappears. This is particularly odd when you go from your 'my forums' list to a comments thread from Reg Hardware, and you aren't logged in on that domain, so can't check out the latest post.

      I vaguely recall that someone may have raised that bug already, but can't find it. So sorry if I'm repeating.

Page:

This topic is closed for new posts.

Biting the hand that feeds IT © 1998–2022